Project

General

Profile

Bug #6390

ISO size differ without an obvious reason

Added by alant about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
Start date:
10/29/2013
Due date:
% Done:

50%

Feature Branch:
bugfix/6390-dont-include-APT-lists-and-cache-in-the-ISO
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

During release process QA, it has been discovered that ISO size differ without an obvious reason:

- 0.19: 906.5M
- 0.20: 897.3M
- 0.20.1: 925.4M
- 0.21: 934.5M

It might be related to the build system used to build the ISO.


Related issues

Related to Tails - Feature #12238: Ship full APT lists in the live file system Confirmed 02/14/2017

Associated revisions

Revision e19a85c4 (diff)
Added by Tails developers almost 6 years ago

Don't include APT lists and downloaded .deb's in the ISO (Closes: #6390).

History

#1 Updated by intrigeri about 6 years ago

- 0.20.1: 925.4M
- 0.21: 934.5M

0.21 has the Debian testing sources added. It probably accounts for some, if not all, of the size increase.

However, it's correct that we have already noted (like, since a year
or more) that ISO's built with Vagrant (by anonym, at least) are
noticeably smaller than ISO's built with libvirt (by intrigeri, at
least).

#2 Updated by intrigeri about 6 years ago

intrigeri wrote:

However, it's correct that we have already noted (like, since a year
or more) that ISO's built with Vagrant (by anonym, at least) are
noticeably smaller than ISO's built with libvirt (by intrigeri, at
least).

It might be that "my" ISO images have stuff they should not have in /var/lib/apt/lists/. To be investigated.

#3 Updated by winterfairy about 6 years ago

Tails 0.21 has 4 files in "/var/cache/apt/archives/partial" too :)
Only 1 MB however.

/var/lib/apt/lists/* is 127.5 MB uncompressed, which is just above 25 MB compressed on the ISO (and each IUK update, since they always change).

#4 Updated by intrigeri almost 6 years ago

live-build 3.x passes config/rootfs/excludes as a parameter to mksquashfs' -ef (exclude file) option.
But we already have a file passed as -ef in config/chroot_local-includes/usr/share/amnesia/build/mksquashfs-excludes.

#5 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/6390-dont-include-APT-lists-and-cache-in-the-ISO

#6 Updated by intrigeri almost 6 years ago

  • Assignee changed from intrigeri to anonym
  • Target version set to Tails_0.23
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA
  • Type of work changed from Research to Code

Works for me, going to ask for a review'n'merge.

#7 Updated by intrigeri almost 6 years ago

  • Status changed from In Progress to 11

#8 Updated by intrigeri almost 6 years ago

  • QA Check changed from Ready for QA to Pass

#9 Updated by intrigeri almost 6 years ago

  • Assignee deleted (anonym)

#10 Updated by anonym over 5 years ago

  • Status changed from 11 to Resolved

#11 Updated by sajolida almost 2 years ago

  • Related to Feature #12238: Ship full APT lists in the live file system added

Also available in: Atom PDF