Project

General

Profile

Feature #6387

Create screencast videos of installing Tails onto a USB stick

Added by sajolida over 5 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Installation
Target version:
-
Start date:
01/08/2015
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

I might be useful for some people to have a screencast video explaining how to install Tails onto a USB stick. This should reuse the written documentation, and might even be an opportunity to review it.


Subtasks

Feature #8610: Create a screencast video of installing Tails onto a USB stick - from WindowsRejected

Feature #8611: Create a screencast video of installing Tails onto a USB stick - from Mac OSXRejected

Feature #8612: Create a screencast video of installing Tails onto a USB stick - from Linux (CLI and GUI)Rejected


Related issues

Related to Tails - Bug #6851: Fix ISO verification using checksum Resolved 08/16/2013
Related to Tails - Feature #6853: Give an overview of the workflow from downloading an ISO to having a working persistent volume Duplicate 03/06/2014
Related to Tails - Feature #7492: Explain graphically different steps of a typical use of Tails through photos or screencast Rejected 07/06/2014
Blocked by Tails - Feature #8581: Analyse and simplify the installation and upgrade workflows Resolved 04/07/2014

History

#1 Updated by sajolida almost 5 years ago

  • Category set to Installation

#2 Updated by intrigeri almost 5 years ago

  • Tracker changed from Bug to Feature

#3 Updated by intrigeri almost 5 years ago

  • Related to Feature #7492: Explain graphically different steps of a typical use of Tails through photos or screencast added

#4 Updated by spriver almost 5 years ago

  • Assignee set to spriver

#5 Updated by spriver almost 5 years ago

First ideas on that:
-Downloading, verifying and signing a Tails iso on windows (atm I have a Windows 7 machine), I could also do that on Debian (in terminal)
-Installing the iso to a DVD
-Booting up the DVD
-Installation of tails on USB with the tails-installer
-Some helpful links at the end for troubleshooting (known issues page, mailing lists etc.)

Perhaps also the manual installation could be shown on Windows and Linux (in a seperate video)

#6 Updated by sajolida almost 5 years ago

  • Related to deleted (Feature #7492: Explain graphically different steps of a typical use of Tails through photos or screencast)

#7 Updated by sajolida almost 5 years ago

  • Related to Feature #6853: Give an overview of the workflow from downloading an ISO to having a working persistent volume added

#8 Updated by sajolida almost 5 years ago

  • Related to Bug #6851: Fix ISO verification using checksum added

#9 Updated by sajolida almost 5 years ago

First ideas on that:
-Downloading, verifying and signing a Tails iso on windows (atm I have a Windows 7 machine), I could also do that on Debian (in terminal)
-Installing the iso to a DVD
-Booting up the DVD
-Installation of tails on USB with the tails-installer
-Some helpful links at the end for troubleshooting (known issues page, mailing lists etc.)

Perhaps also the manual installation could be shown on Windows and Linux (in a seperate video)

Thanks for moving this forward!

This ticket is called "Create a screencast video of installing Tails
onto a USB stick", and the main issue I see here is that there are
several ways of achieve this, even for people on Windows: you can burn a
DVD and then clone, or do the manual installation and then clone. Our
experience showed that the complicated part is to understand the
workflow, and this relates to #6853.

So we should plan on having I would say three videos to start with:

1. Downloading and verifying on Windows
2a. Burn a DVD and cloning
2b. Manual installation and cloning

Also note that currently it is only documented how to verify the ISO
with OpenPGP. Are you planning to document that in your screencast using
Kleopatra?

As a general comment as well, the best screencasts I've see in the past,
the ones that were the most clear to look at were actually reading
written documentation out loud and showing the steps visually. That
means that a first thing to do is for you to check that the written
documentation works by being read out loud. And if not, work together to
fix that. I'm very interested in doing that work, but I need an external
point of view, like yours, on the doc.

Working like this will also allow us to agree on the spoken content of
the screencast before you recording it and avoid round-trips.

#10 Updated by spriver almost 5 years ago

sajolida wrote:

First ideas on that:
-Downloading, verifying and signing a Tails iso on windows (atm I have a Windows 7 machine), I could also do that on Debian (in terminal)
-Installing the iso to a DVD
-Booting up the DVD
-Installation of tails on USB with the tails-installer
-Some helpful links at the end for troubleshooting (known issues page, mailing lists etc.)

Perhaps also the manual installation could be shown on Windows and Linux (in a seperate video)

Thanks for moving this forward!

This ticket is called "Create a screencast video of installing Tails
onto a USB stick", and the main issue I see here is that there are
several ways of achieve this, even for people on Windows: you can burn a
DVD and then clone, or do the manual installation and then clone. Our
experience showed that the complicated part is to understand the
workflow, and this relates to #6853.

So we should plan on having I would say three videos to start with:

1. Downloading and verifying on Windows
2a. Burn a DVD and cloning
2b. Manual installation and cloning

Also note that currently it is only documented how to verify the ISO
with OpenPGP. Are you planning to document that in your screencast using
Kleopatra?

As a general comment as well, the best screencasts I've see in the past,
the ones that were the most clear to look at were actually reading
written documentation out loud and showing the steps visually. That
means that a first thing to do is for you to check that the written
documentation works by being read out loud. And if not, work together to
fix that. I'm very interested in doing that work, but I need an external
point of view, like yours, on the doc.

Working like this will also allow us to agree on the spoken content of
the screencast before you recording it and avoid round-trips.

This sounds good, especially the idea of the three videos. I think that most newbies are coming from Windows and that this would be the most important part. The verifying with Kleopatra is also an important issue to cover. Later we could also create some videos for terminal installation under e.g. linux.
Your suggestion with the read out documentation is also a good point. It would also proof if the doc is clearly to understand at the moment.
I will have a look at that in the next days. I'm also very interested in that task because it would make it very much more easy to start using Tails.

#11 Updated by BitingBird over 4 years ago

  • Subject changed from Create a screencast video of installing Tails onto a USB stick to Create screencast videos of installing Tails onto a USB stick

#12 Updated by sajolida over 4 years ago

  • Blocked by Feature #8581: Analyse and simplify the installation and upgrade workflows added

#13 Updated by sajolida about 4 years ago

  • Assignee deleted (spriver)

I'm more and more convinced that this work will be very hard (if not pointless) to do before we have the ISO verification extension (see https://tails.boum.org/blueprint/bootstrapping/extension) and probably the web assistant (https://tails.boum.org/blueprint/bootstrapping/assistant/) since this will completely rewrite the documentation.

Once we get there I think it should document the path for Windows users:

  • Download through HTTP
  • Verify the ISO using the Firefox extension
  • Install using UUI
  • Clone

People willing to work on this should actively review and comment on the work that we will be doing on the assistant to make sure it's compatible with the screencast format. More on that later...

#15 Updated by sajolida about 4 years ago

  • Related to deleted (Feature #6853: Give an overview of the workflow from downloading an ISO to having a working persistent volume)

#16 Updated by sajolida about 4 years ago

  • Related to Feature #6853: Give an overview of the workflow from downloading an ISO to having a working persistent volume added

#17 Updated by u almost 2 years ago

  • Related to Feature #7492: Explain graphically different steps of a typical use of Tails through photos or screencast added

#18 Updated by sajolida almost 2 years ago

  • Type of work changed from End-user documentation to Discuss
  • Starter deleted (Yes)

For some reason, I've been the one to open this ticket years ago though I never clarified my personal opinion on this in this ticket. I actually think it's a bad idea and we shouldn't put that much energy into this project and we should reject this ticket and its subtickets, and for the following reasons:

  • Following the full installation assistant for Windows for example takes about 1 hour (download not included) so the video would be that 1-hour long.
  • Producing such videos (Windows, macOS, and possibly several different for Linux) would be a lot of work, while the benefits are uncertain: how many people would really find it easier to follow 1-hour long video instead of our current step-by-step instructions?
  • Videos are notoriously hard to mantain, so producing a one-shot video without having a way to make it easier to update the video as our installation procedure changes would make the video outdated very quickly. For example, in 2017 only we did the following changes to the installation assistant that would have required an updated video:
    • Ubuntu graphical configuration of PPA
    • Update Debian instructions to Stretch
    • Rename to macOS
    • Remove Torrents and reintroduce them
    • Update to 3.0
      • New Greeter
      • Change to amd64
      • New GNOME Disks
    • Change in interface of UUI 1.9.7.7
    • DVD burning in El Capitan
  • The instructions are not exactly linear, for example for the different download technique or in case people have to fallback to troubleshooting instructions. This would make the creation of such a video even more complicated and more complicated for the user. In the case of the troubleshooting sections:
    • You would either have to watch tons of troubleshooting instructions that you don't really need.
    • Or switch back to troubleshooting instructions on the website or in dedicated videos.

All-in-all, I don't think it's worth putting that much energy into solving this properly. Quick-and-dirty solutions would be still tons of work and outdated in a matter of months.

#19 Updated by intrigeri almost 2 years ago

All-in-all, I don't think it's worth putting that much energy into solving this properly. Quick-and-dirty solutions would be tons of work and outdated in a matter of months.

Your reasoning makes sense. I'm convinced.

#20 Updated by sajolida over 1 year ago

  • Assignee set to sajolida

#21 Updated by nodens over 1 year ago

  • Status changed from Confirmed to Rejected

This ticket was discussed during the monthly meeting (November 2017).
Here is a summary of the discussion / decision:

Discussion summary

Decision:

Reject this ticket. We acknowledge that such videos could be useful, but we can't maintain them ourselves

Please refer to the meeting notes for detail (including full log): https://tails.boum.org/contribute/meetings/201711/

Also available in: Atom PDF