Project

General

Profile

Bug #6377

Web browser window size is not set to a multiple of 200x100

Added by intrigeri about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
10/19/2013
Due date:
% Done:

100%

Feature Branch:
feature/torbutton-1.6.11.1
Type of work:
Upstream
Blueprint:
Starter:
No
Affected tool:
Browser

Description

This is https://trac.torproject.org/projects/tor/ticket/8478, partially fixed by commit 5e5c5bd41 in Torbutton 1.6.x.

We have cherry-picked this patch in Tails 0.21, but it's not enough.

See also https://trac.torproject.org/projects/tor/ticket/10095 and https://trac.torproject.org/projects/tor/ticket/9268.


Related issues

Blocked by Tails - Feature #7662: Upgrade to Torbutton 1.6.11.1 Resolved 07/25/2014 08/11/2014

Associated revisions

Revision 90cda608 (diff)
Added by Tails developers almost 6 years ago

Use small icons in the web browser's navigation toolbar (Closes: #6377).

We're actually hit by Tor#9268, and this is the best workaround gk and I were
able to find when discussing this on Tor#10095.

Long-term, "Some future logic to fully take toolbars into consideration would be
independent of this", as gk says.

History

#1 Updated by intrigeri about 6 years ago

  • Assignee deleted (intrigeri)

#2 Updated by intrigeri about 6 years ago

  • Category set to 176
  • Type of work changed from Code to Upstream

#3 Updated by intrigeri about 6 years ago

Seems to be fixed in 0.22. Should be tested and confirmed.

#4 Updated by intrigeri almost 6 years ago

  • Subject changed from Web browser resolution not set to a multiple of 200x100 to Web browser window size is not set to a multiple of 200x100

#5 Updated by intrigeri almost 6 years ago

  • Assignee set to alant
  • Target version set to Tails_0.22.1
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/6377-workaround-for-window-size

Workaround'ed in bugfix/6377-workaround-for-window-size.

#6 Updated by alant almost 6 years ago

  • Status changed from Confirmed to 11
  • Assignee deleted (alant)
  • QA Check changed from Ready for QA to Pass

#7 Updated by intrigeri almost 6 years ago

  • Status changed from 11 to Resolved

#8 Updated by intrigeri over 5 years ago

  • Status changed from Resolved to In Progress
  • Assignee set to intrigeri
  • Target version changed from Tails_0.22.1 to Tails_1.1.1
  • QA Check deleted (Pass)

The workaround doesn't always work: I've seen 1000x587 while testing 1.1~rc1. It seems that torbutton 1.6.10.1 should improve things a bit (commit 32003e19d4a). Unfortunately, nobody took care of updating torbutton during the 1.1 release cycle (probably due to unclear responsibility boundaries), so that'll be for 1.1.1.

#9 Updated by intrigeri over 5 years ago

#10 Updated by intrigeri over 5 years ago

  • Related to deleted (Feature #7662: Upgrade to Torbutton 1.6.11.1)

#11 Updated by intrigeri over 5 years ago

#12 Updated by intrigeri over 5 years ago

  • Feature Branch changed from bugfix/6377-workaround-for-window-size to feature/torbutton-1.6.11.1

Seems to be fixed with torbutton 1.6.11.1.

#13 Updated by intrigeri over 5 years ago

  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

#14 Updated by BitingBird over 5 years ago

  • Assignee set to alant

assigning to alan, according to his mail

#15 Updated by alant over 5 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (alant)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

I confirm I can't reproduce this bug in experimental 19997e6 with a screen resolution of 1152x870 while I can with 1.1.

#16 Updated by anonym over 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF