Project

General

Profile

Bug #6374

Tries to delete persistent volume even if persistence is enabled

Added by intrigeri about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Persistence
Target version:
-
Start date:
10/18/2013
Due date:
% Done:

0%

Feature Branch:
bugfix/world-readable-persistence-state-file
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

In 0.21~rc1, "Delete persistent volume" tries to do its job, while it should error out with "Cannot delete the persistent volume while in use. You should restart Tails without persistence."

That's a regression against 0.20.1.

That's because the dedicated t-p-s user can't read /var/lib/live/config/tails.persistence.

History

#1 Updated by intrigeri about 6 years ago

  • Feature Branch set to bugfix/world-readable-persistence-state-file

#2 Updated by intrigeri about 6 years ago

  • Assignee deleted (intrigeri)
  • QA Check set to Ready for QA

#3 Updated by bertagaz about 6 years ago

  • Assignee set to bertagaz

#4 Updated by bertagaz about 6 years ago

  • Status changed from Confirmed to 11
  • Assignee deleted (bertagaz)
  • QA Check changed from Ready for QA to Pass

#5 Updated by intrigeri about 6 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF