Project

General

Profile

Feature #6368

Feature #5663: Return to Icedove

Feature #6148: Torbirdy in Debian

Feature #6154: Secure the Icedove autoconfig wizard

Test our rebased patches on Icedove 38

Added by intrigeri over 5 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/16/2013
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
No
Affected tool:
Email Client

History

#1 Updated by BitingBird about 5 years ago

  • Category set to 176

#2 Updated by intrigeri about 5 years ago

  • Category deleted (176)

Icedove is a mail client, not a browser.

#3 Updated by anonym about 5 years ago

  • Due date set to 05/31/2014
  • Assignee set to anonym

#4 Updated by BitingBird about 5 years ago

  • Category set to 176

#5 Updated by BitingBird about 5 years ago

  • Category deleted (176)

#6 Updated by BitingBird almost 5 years ago

The due date is in the past, should it be removed ?

#7 Updated by sajolida almost 5 years ago

  • Priority changed from High to Normal

#8 Updated by BitingBird almost 5 years ago

  • Due date deleted (05/31/2014)

#9 Updated by intrigeri almost 5 years ago

  • Subject changed from Test our rebased patches on Icedove 24 to Test our rebased patches on Icedove 31

#10 Updated by intrigeri almost 5 years ago

  • Category set to 212

#11 Updated by anonym over 4 years ago

  • Assignee deleted (anonym)
  • QA Check set to Info Needed

This ticket is blocked by #6369 ("Build Debian packages of Icedove 31 with our patches") which is blocked by #7746 ("Rebase our patches on top of Icedove 31"). I could do at least #7746 if it would help to get things rolling, but I sort of remember that it has landed on someone else's plate (u?). I'm not even sure if it's accurate that this ticket is assigned to me.

However, I just looked into my icedove Git source tree (I was gonna update #7746 with some specifics), and it seems I already did such a rebase (against 31.3.0-1_deb7u1) in early December, and then forgot about it. I can't say that I remember if I actually tested it. So how do we proceed here?

#12 Updated by intrigeri over 4 years ago

Please just push the current state of your work to Git, and point to it on #7746.

#13 Updated by intrigeri over 4 years ago

  • QA Check deleted (Info Needed)

#14 Updated by intrigeri about 4 years ago

  • Subject changed from Test our rebased patches on Icedove 31 to Test our rebased patches on Icedove 38
  • Assignee set to u
  • Target version set to 246

Icedove 38 will be out soon, so before the work on Icedove actually starts.

#16 Updated by sajolida over 3 years ago

  • Target version changed from 246 to Tails_2.0

#17 Updated by u over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

Postponing. A packaging branch is ready, but the package has to be tested in Tails.

#18 Updated by u over 3 years ago

I've now tested this using my built package in Debian Sid, with a similar configuration than the Tails one.
(I did not yet test in Tails because I've not created a package for i386 AND stable).

Tested the account creation wizard, which worked well.

I realized that
  • we will probably need to set "vendor=Tails" in Torbirdy, so that automatic account creation will be enabled. Currently this is disabled by default in Torbirdy.
  • We will also need to set "use secure protocols only" to true in Torbirdy. This should be done upstream and will be useful only once our patches are merged, or, if we use our own build of Icedove.

#19 Updated by u over 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

#20 Updated by u over 3 years ago

Next steps:
  • build i386/stable packages and retest in Tails.
  • Make testing more thourough, using wireshark for example (look at manual test suite for Icedove).

#21 Updated by intrigeri over 3 years ago

Tested the account creation wizard, which worked well.

Yay!

I realized that
  • we will probably need to set "vendor=Tails" in Torbirdy, so that automatic account
    creation will be enabled. Currently this is disabled by default in Torbirdy.
  • We will also need to set "use secure protocols only" to true in Torbirdy.
    This should be done upstream and will be useful only once our patches are merged, or,
    if we use our own build of Icedove.

Please make sure this is written down on the relevant ticket too :)
(if not done yet, of course)

#22 Updated by anonym over 3 years ago

intrigeri wrote:

u wrote:

  • we will probably need to set "vendor=Tails" in Torbirdy, so that automatic account
    creation will be enabled. Currently this is disabled by default in Torbirdy.

I do not get that part. It seems this was added by them thinking that we already was shipping Icedove with these patches applied. I prefer us simply setting extensions.torbirdy.emailwizard, which controls the same thing, and is what I implemented in feature/6154-secure-autoconfig-in-icedove. I'd rather propose upstream to remove this special case.

  • We will also need to set "use secure protocols only" to true in Torbirdy.
    This should be done upstream and will be useful only once our patches are merged, or,
    if we use our own build of Icedove.

Done in the branch.

Please make sure this is written down on the relevant ticket too :)
(if not done yet, of course)

I think we're done already.

To end with, my initial testing reported in #6158#note-22 looks very promising, to the extent where we can close this ticket.

#23 Updated by intrigeri over 3 years ago

It seems this was added by them thinking that we already was shipping Icedove with these patches applied.

I'm pretty sure we actually asked them to add this pref.

#24 Updated by u over 3 years ago

  • Status changed from In Progress to Fix committed

anonym wrote:

intrigeri wrote:

u wrote:

  • we will probably need to set "vendor=Tails" in Torbirdy, so that automatic account
    creation will be enabled. Currently this is disabled by default in Torbirdy.

I do not get that part. It seems this was added by them thinking that we already was shipping Icedove with these patches applied. I prefer us simply setting extensions.torbirdy.emailwizard, which controls the same thing, and is what I implemented in feature/6154-secure-autoconfig-in-icedove. I'd rather propose upstream to remove this special case.

Correct, that's what they thought apparently.
Then let's track this in https://labs.riseup.net/code/issues/10977

  • We will also need to set "use secure protocols only" to true in Torbirdy.
    This should be done upstream and will be useful only once our patches are merged, or,
    if we use our own build of Icedove.

Done in the branch.

Please make sure this is written down on the relevant ticket too :)
(if not done yet, of course)

I think we're done already.

To end with, my initial testing reported in #6158#note-22 looks very promising, to the extent where we can close this ticket.

#25 Updated by u over 3 years ago

  • Status changed from Fix committed to In Progress

#26 Updated by u over 3 years ago

  • Blocked by deleted (Feature #6369: Build Debian packages of Icedove 38 with our patches / create proper branch situation)

#27 Updated by u over 3 years ago

  • Status changed from In Progress to Resolved

#28 Updated by intrigeri about 3 years ago

  • Assignee deleted (u)
  • % Done changed from 10 to 100

Also available in: Atom PDF