Project

General

Profile

Feature #6361

Feature #6165: Improve visually the Contribute section

Create a stylesheet for the contributor's role

Added by sajolida over 6 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
10/11/2013
Due date:
% Done:

0%

Feature Branch:
Type of work:
Website
Blueprint:
Starter:
Yes
Affected tool:

Description

The top of the "Contribute" page is structured by logical blocks, divided by skills first, and then by role. Some CSS styling should make this logical structure more visible and easy to navigate visually.

The CSS selectors for this section are already defined in the "Contribute section" part of the local.css, only the artwork is missing. Maybe not much is needed...

History

#1 Updated by sajolida about 6 years ago

  • Blueprint set to https://tails.boum.org/blueprint/contribute

#2 Updated by BitingBird about 6 years ago

It looks like the contribute blueprint has been merged, and the blueprint link goes to a redirection page. Is this issue still standing ?

#3 Updated by intrigeri about 6 years ago

  • Blueprint deleted (https://tails.boum.org/blueprint/contribute)

BitingBird wrote:

It looks like the contribute blueprint has been merged, and the blueprint link goes to a redirection page.

Indeed. Removed that obsolete link, nice catch!

Is this issue still standing ?

Yes: we merged the new contribute page without waiting for an improved CSS, as it seemed to us that it vastly improved the state of things. But there's still quite some room for the styling improvements documented on this ticket :)

#4 Updated by sajolida almost 6 years ago

  • Description updated (diff)

#5 Updated by sajolida over 5 years ago

  • Target version set to 239

#6 Updated by sajolida over 5 years ago

  • Target version deleted (239)

#7 Updated by BitingBird about 5 years ago

Either the goal should be better defined, or the "easy" tag should be removed.

#8 Updated by sajolida about 5 years ago

  • Priority changed from Normal to Low

My idea when creating that ticket was to leave room for the creativity of the designer to improve on that page visually through CSS only. It is marked as "easy" because it doesn't require building the wiki and can be done as a first standalone and small project for someone knowing CSS.

On the other hand, I'm really fine with the way this page looks right now, so I'm marking this as low priority. Feel free to close it if you think that it's not worth polluting our Redmine.

#9 Updated by BitingBird about 5 years ago

  • Status changed from Confirmed to Resolved

Well, I think the Contribute page is one of our most beautiful, so I think this could be closed, and another opened when someone has more specific ideas of what / how to improve.

Also available in: Atom PDF