Project

General

Profile

Feature #6297

Feature #5926: Freezable APT repository

Feature #9489: Implement packages importing and freezing

Save list of packages used at ISO build time

Added by intrigeri almost 6 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Elevated
Assignee:
-
Category:
Build system
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
feature/5926-freezable-APT-repository
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

At ISO build time, generate a list of used packages and version, including packages used at build time but not shipped in the ISO.

See #5548 for implementation ideas and pointers to how others do.

Note that this highly depends on #9487: it might be that we decide it's simpler to import the full APT suites we're interested in, instead of a subset of their packages.


Related issues

Related to Tails - Feature #8518: Initial rough implementation of saving list of packages used at ISO build time Resolved 01/03/2015
Duplicates Tails - Feature #10748: Generate a manifest of packages used at build time Resolved 12/13/2015

History

#1 Updated by intrigeri over 5 years ago

  • Category set to Build system
  • Type of work changed from Sysadmin to Code

#2 Updated by BitingBird about 5 years ago

  • Priority changed from Normal to Elevated
  • Target version set to Sustainability_M1

Setting priority and target version according to parent ticket

#3 Updated by intrigeri over 4 years ago

  • Blocks Feature #8512: Have reproducible.debian.net track the status of the Debian packages we use added

#4 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to feature/6297-save-packages-list

#5 Updated by intrigeri over 4 years ago

  • Feature Branch deleted (feature/6297-save-packages-list)

#6 Updated by intrigeri over 4 years ago

  • Blocks deleted (Feature #8512: Have reproducible.debian.net track the status of the Debian packages we use)

#8 Updated by intrigeri about 4 years ago

  • Assignee set to intrigeri
  • Target version changed from Sustainability_M1 to Tails_2.3

#9 Updated by intrigeri about 4 years ago

  • Blocks deleted (Feature #6299: Regularly pull packages from foreign APT repositories)

#10 Updated by intrigeri about 4 years ago

  • Parent task changed from #5926 to #9489

#11 Updated by intrigeri about 4 years ago

  • Target version changed from Tails_2.3 to Tails_2.2

#12 Updated by intrigeri about 4 years ago

  • Description updated (diff)

#14 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to CyrilBrulebois

#15 Updated by intrigeri almost 4 years ago

  • Related to Feature #8518: Initial rough implementation of saving list of packages used at ISO build time added

#16 Updated by intrigeri almost 4 years ago

  • % Done changed from 100 to 10

#17 Updated by intrigeri over 3 years ago

  • Assignee changed from CyrilBrulebois to intrigeri
  • % Done changed from 10 to 50
  • Feature Branch set to feature/5926-freezable-APT-repository

I've merged Cyril's pu/stable-v1 into feature/5926-freezable-APT-repository, and pushed a few more commits on top:

5837dd3f2e70b392af52d69a405e55fe4c791603 Retrieve information about packages used during the build.
ad10420884f0e52b6ad0bf58857b76de9b10c2fe Don't include /debootstrap in the SquashFS.
778668b988e539fdcda6a98ca1019227422ae3b9 auto/build: move option setting to a more consistent place.
322e6c0d72c97c033e60c73db5bf96f477a6bc83 Document the need for debootstrap 1.0.73+.
0ae53cb8ba45656fb1d8702c33fa55a9626d8f52 Fix shebang.

I'm happy with the generated .{bin,deb,src}uris files, yay!

Now, due to the dependency on a newer debootstrap, merging this into one of our release branches is blocked by #9262.

#18 Updated by intrigeri over 3 years ago

  • Blocked by Bug #9262: Port our ISO build system to Jessie added

#19 Updated by intrigeri over 3 years ago

  • Blocks Feature #10748: Generate a manifest of packages used at build time added

#20 Updated by intrigeri over 3 years ago

  • Blocked by deleted (Bug #9262: Port our ISO build system to Jessie)

#21 Updated by intrigeri over 3 years ago

  • Blocked by Feature #7642: Investigate whether we should resume shipping a static random seed added

#22 Updated by intrigeri over 3 years ago

(Actually, we can very well use debootstrap from jessie-backports on a Wheezy build system. So, what blocks us from completing this ticket is #7642, not #9262.)

#23 Updated by intrigeri over 3 years ago

  • Blocks deleted (Feature #10748: Generate a manifest of packages used at build time)

#24 Updated by intrigeri over 3 years ago

  • Blocks Feature #10748: Generate a manifest of packages used at build time added

#25 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.0

#26 Updated by intrigeri over 3 years ago

  • Priority changed from Normal to Elevated
  • Target version changed from Tails_2.0 to Tails_2.2

#27 Updated by intrigeri over 3 years ago

  • Blocked by deleted (Feature #7642: Investigate whether we should resume shipping a static random seed)

#28 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#30 Updated by intrigeri over 3 years ago

  • Blocks deleted (Feature #10748: Generate a manifest of packages used at build time)

#31 Updated by intrigeri over 3 years ago

  • Duplicates Feature #10748: Generate a manifest of packages used at build time added

#32 Updated by intrigeri over 3 years ago

  • Related to deleted (Feature #5548: Research ways to distribute source)

#33 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Duplicate
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100

This will be tracked on #10748 since we don't need that fine-grained tracking.

Also available in: Atom PDF