Project

General

Profile

Bug #6294

Feature #6015: Tails based on Wheezy

NetworkManager in Wheezy resets MAC address to the inital one once disconnected

Added by sajolida almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
03/10/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Upstream
Blueprint:
Starter:
No
Affected tool:

Description

See GNOME bug 708820

Even once this is fixed upstream (for Jessie), we might want to simply comment out the resetting code in NM (as long as Tails is based on Wheezy). After a quick look at the code, it seems to be a one line change in two places.


Subtasks

Feature #6890: Test MAC spoofing on Wheezy for hot-plugged network interfacesResolvedintrigeri

History

#1 Updated by intrigeri almost 6 years ago

  • Parent task set to #6015

#2 Updated by sajolida almost 6 years ago

  • Subject changed from NetworkManager in Wheezy resets MAC address to the permanent one once disconnected to NetworkManager in Wheezy resets MAC address to the inital one once disconnected
  • Priority changed from Elevated to Normal

Actually, we misunderstood the issue. The MAC address is not reset to the permanent one, but to the one it had when NetworkManager was started.

#3 Updated by intrigeri almost 6 years ago

  • Priority changed from Normal to Elevated

#4 Updated by intrigeri almost 6 years ago

  • Target version deleted (Tails_1.1)

#5 Updated by intrigeri almost 6 years ago

  • Assignee set to intrigeri

#6 Updated by intrigeri almost 6 years ago

  • Target version set to Tails_1.1

#7 Updated by intrigeri over 5 years ago

Unless I'm mistaken, once feature/spoof-mac is merged, this is a non-issue: we only start NetworkManager after spoofing the MAC address.

#8 Updated by intrigeri over 5 years ago

Confirmed, this issue will go away once #5421 is solved.

#9 Updated by intrigeri over 5 years ago

  • Description updated (diff)

#10 Updated by anonym over 5 years ago

I feel quite confident that #5421 fixes this issue.

It's very clear that any device physically plugged before logging in in the Greeter will be unaffected since NM is started after all those devices has been spoofed. It's a bit less clear about devices plugged after logging in but from what I remember from an earlier investigation, NM won't handle any devices until all udev hooks (and hence MAC spoofing) have finished. Thus NM should only ever see the spoofed MAC address, and from my understanding of the upstream bug, that solves our issue.

#11 Updated by intrigeri over 5 years ago

Confirmed, that's a non-issue both for {cold,hot}-plugged devices.

#12 Updated by intrigeri over 5 years ago

#13 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Resolved

The testing branch (and hence, the feature/spoof-mac one) was merged into feature/wheezy, so that's now a non-issue as long as one does not play with macchanger manually.

Also available in: Atom PDF