Project

General

Profile

Feature #6274

Bug #5518: Make the system disk read-only

Bug #6172: Fix write access to boot medium via udisks

Research consequences of the boot device being seen as system internal by udisks

Added by intrigeri about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
03/31/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:

Description

In our Wheezy branch, the boot device is seen as system internal by udisks. What are the consequences on t-p-s, incremental upgrades, Tails Installer etc.?

With the 20131226 nightly build of feature/wheezy:

  • Tails Installer just works, as the destination USB stick is writable by the floppy group.
  • Creating and deleting the persistent volume works, as expected (we explicitly grant the t-p-s user permission to do so).

Subtasks

Feature #7005: Test incremental upgrades on WheezyResolvedintrigeri

Feature #7006: Check if we document how to modify the current Tails boot device with GNOME DisksResolvedintrigeri


Related issues

Blocks Tails - Feature #6015: Tails based on Wheezy Resolved 07/28/2013

History

#1 Updated by intrigeri almost 6 years ago

  • Subject changed from Research consequences of the boot device being seen as "system internal" by udisks to Research consequences of the boot device being seen as system internal by udisks

#2 Updated by BitingBird over 5 years ago

  • Target version set to Tails_1.1

Since it's marked as blocking Tails-Wheezy, I logically set the 1.1 Target version :)

#3 Updated by intrigeri over 5 years ago

  • Description updated (diff)

#4 Updated by intrigeri over 5 years ago

  • Assignee set to intrigeri

#5 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to sajolida

sajolida, please close this ticket as resolved once you've dealt with #7006, as I have nothing left to do on this front. Thanks!

#6 Updated by intrigeri over 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from sajolida to intrigeri

Also available in: Atom PDF