Project

General

Profile

Feature #6271

Use GNOME GnuPG agent

Added by intrigeri about 6 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
09/10/2013
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

It would be overall nicer (and safer when using GNOME Shell, due to the way the passphrase window takes over the desktop in ways that no other process can fake) to use the GNOME GnuPG agent instead of the regular one.
Moreover, it's likely that i18n bugs such as #6206 don't affect the GNOME agent.

For the record, we had two reasons to move to gpg-agent + pinentry (#5419):

  1. the dreaded desktop lock bug (#5586), which is fixed on Wheezy
  2. OpenPGP smartcards support (#5931)

Subtasks

Feature #6272: Wait for GNOME GnuPG agent to support OpenPGP smartcardsRejected

Feature #11637: Verify that GNOME still doesn't support smartcardsResolved


Related issues

Blocked by Tails - Feature #6015: Tails based on Wheezy Resolved 07/28/2013
Blocked by Tails - Feature #5586: Test if "desktop crashes with claws-mail and Seahorse GPG agent" fixed on Wheezy Resolved

History

#1 Updated by alant about 3 years ago

  • Status changed from Confirmed to Rejected

There is no GNOME gnupg agent anymore, but only a pinentry, so let's close this bug.

Also available in: Atom PDF