Project

General

Profile

Bug #6244

Pidgin freezes when the network connection is reestablished

Added by sajolida about 6 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/15/2013
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:

Description

- Start Tails 0.19 in a virtual machine
- Connect to the network
- Start Pidgin and open the #tails channel
- Disconnect from the network with NetworkManager
- Reconnect to the network

Then the Pidgin window turns grey. It can be minimized but the application cannot be closed from the notification area.

We didn't managed to reproduce that with Debian Sid, nor in a Tails based on Wheezy.

History

#1 Updated by alant over 5 years ago

Somebody wrote us:

I would interprete 6244 as "not yet reconnected" - Pidgin appears pretty slow in recognizing disconnects and reconnecting In real life as well as from messages like "abc left the room (quit: Ping timeout: 480 seconds)

You might want to lower the timeouts.

#2 Updated by intrigeri over 5 years ago

Can this be reproduced with Tails 0.22.1, that ships a newer Pidgin (the same as the one in sid, actually)?

#3 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Fix committed
  • Target version set to Tails_1.1
  • % Done changed from 0 to 100

I still can't reproduce this on current Tails/Wheezy, so marking as fix committed for that version.

#4 Updated by intrigeri over 5 years ago

#5 Updated by BitingBird over 5 years ago

There is no fix commited, that should be marked resolved, no ?

#6 Updated by intrigeri over 5 years ago

There is no fix commited, that should be marked resolved, no ?

It's broken in current Tails, and will be fixed in 1.1. That's what "fix committed" means.

Be the fix caused by an actual Git commit or something else is
a low-level implementation detail, that we don't care much about as
far as the Status field is concerned :)

#7 Updated by BitingBird about 5 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF