Project

General

Profile

Feature #6236

Feature #5709: VoIP support

Test Jitsi for VoIP and XMPP

Added by akuckartz over 6 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
08/11/2013
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Related issues

Related to Tails - Feature #14567: Investigate mobile messaging applications Confirmed 01/18/2018

History

#1 Updated by akuckartz over 6 years ago

See #5709

#2 Updated by intrigeri over 6 years ago

  • Assignee set to akuckartz
  • Parent task set to #5709

#3 Updated by akuckartz over 6 years ago

A Jitsi issue to monitor:

Jitsi leaks DNS when using a proxy
https://trac.jitsi.org/ticket/1060

#4 Updated by akuckartz over 6 years ago

Emil Ivov on 2013-08-20 wrote this to the public jitsi-dev mailing list:

"Also, while at the IETF, we had a meeting with Jacob Appelbaum and Linus Nordberg from TOR. We thought that it would be nice to integrate JTor within Jitsi and offer the option of using it without the need to download a dedicated TOR client.

"This would be a nice project too."

Indeed, that would be a great complementary Jitsi-feature.

#5 Updated by intrigeri over 6 years ago

"Also, while at the IETF, we had a meeting with Jacob Appelbaum and Linus Nordberg
from TOR. We thought that it would be nice to integrate JTor within Jitsi and offer
the option of using it without the need to download a dedicated TOR client.

I doubt we want to ship and run a second Tor client in Tails, so I'm
not sure how it relates to the Tails VoIP feature in practice.

#6 Updated by akuckartz over 6 years ago

intrigeri wrote:

I doubt we want to ship and run a second Tor client in Tails, so I'm
not sure how it relates to the Tails VoIP feature in practice.

The advantage of having Tor in Jitsi outside of Tails is that more people will be able to use Jitsi with Tor which potentially will help making deanonymisation more difficult for both kinds of Tor users. The Jitsi version included with Tails does not need that integrated JTor client.

#7 Updated by intrigeri over 6 years ago

  • QA Check set to Info Needed

It's not clear to me what's the actual task to do. akuckartz, may you please clarify?

#8 Updated by akuckartz over 6 years ago

intrigeri wrote:

It's not clear to me what's the actual task to do. akuckartz, may you please clarify?

Sure, thanks for asking. The main task is to integrate Jitsi into Tails so that it can be delivered as part of it.

A subtask (or additional task) is to compile a list of known privacy issues or potential issues. That is to ensure that Jitsi in Tails does not contain avoidable security or privacy issues. The Jitsi issue I linked to above is one of them, but there is a small number of other issues or questions I would like the Tails core developers to know about.

Does this answer the question?

#9 Updated by intrigeri over 6 years ago

akuckartz wrote:

The main task is to integrate Jitsi into Tails so that it can be
delivered as part of it.

I'm glad someone wants to tackle it. Please note that we have been
considering other solutions (Linphone) that may be much easier to get
installed on Tails.

Does this answer the question?

Sure. This looks like an ambitious task to me, so perhaps you want to
create smaller sub-tickets that can be addressed one after the other
(e.g. just trying to actually install Jitsi in Tails/Wheezy would
be a nice start :)

#10 Updated by intrigeri over 6 years ago

  • Status changed from New to Confirmed
  • Priority changed from Normal to Low
  • QA Check deleted (Info Needed)

#11 Updated by intrigeri over 6 years ago

Andreas, do you still plan to work on this?

#12 Updated by akuckartz over 6 years ago

Yes, as soon as I am able to build Tails on Debian unstable. The latest Debian package for Jitsi is from 2013-06-17 and installed fine on Debian unstable.

#13 Updated by intrigeri over 6 years ago

Yes, as soon as I am able to build Tails on Debian unstable.

Cool :)

#14 Updated by BitingBird about 5 years ago

Jitsi is in Debian sid, but some bugs block the transition.

#15 Updated by Anonymous over 2 years ago

Hi Andreas, Tails 3.0 is based on Stretch. If you still plan to work on Jitsi for VoIP & XMPP in Tails, please let us know. Note that we've recently updated our build instructions.

#16 Updated by Anonymous about 2 years ago

  • Related to Feature #14567: Investigate mobile messaging applications added

#17 Updated by Anonymous about 2 years ago

  • Assignee deleted (akuckartz)

No news since three years. Unassigning.

#18 Updated by Anonymous about 2 years ago

  • Subject changed from Jitsi for VoIP and XMPP to Test Jitsi for VoIP and XMPP

..and consider including it in Tails if it works.

#19 Updated by Anonymous about 2 years ago

  • Status changed from Confirmed to Rejected

Jitsi seems to be dead: https://tracker.debian.org/pkg/jitsi. The package has been removed from Debian last year and had not seen any new versions since 2015. I think we can reject this ticket until we find something more suitable.

Also available in: Atom PDF