Project

General

Profile

Bug #6206

Cannot enter passphrase in pinentry when Korean language is selected

Added by intrigeri over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
-
Start date:
07/30/2013
Due date:
% Done:

0%

Feature Branch:
winterfairy:bugfix/ibus
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:

Description

  1. Boot Tails
  2. Select Korean language in the greeter (한국어)
  3. Run whatever operation that opens the pinentry dialog (e.g. gpg --symmetric)
  4. Try to type a passphrase

=> no char placeholder (star) is displayed in the passphrase box.

History

#1 Updated by winterfairy about 6 years ago

Still happens in Tails 0.21.
No keypresses are registered by pinentry, not even ENTER.

Changing keyboard layout with setxkbmap does not solve it. Enabling/disabling the input method doesn't affect it. Unsetting GTK_IM_MODULE and XMODIFIER doesn't help either.

Workaround for gpg: gpg --no-use-agent

#2 Updated by winterfairy about 6 years ago

This affects Japanese and Chinese as well!

And quick searching in Nautilus by just start typing does not work either for these locales, which makes me believe this is not pinentry specific.

#3 Updated by intrigeri about 6 years ago

We'll likely have to switch to an entirely different input method for Wheezy, so I doubt it's worth working on this on our Squeeze branch. This would only delay our long awaited Wheezy release. So, I would suggest attacking this with #5487, and then we can see if this problem is automagically solved in Wheezy or not.

#4 Updated by winterfairy about 6 years ago

Agree. For starters I will test if switching input method solves the problem.

#5 Updated by winterfairy about 6 years ago

  • Assignee set to winterfairy

Removing SCIM makes pinentry work again.
And it still works after installing IBus and writing using it.

Replacing SCIM with IBus seems to be the way to solve the problem :)

#6 Updated by intrigeri about 6 years ago

  • Status changed from Confirmed to In Progress

#7 Updated by winterfairy about 6 years ago

Fixed in branch "bugfix/ibus" in my repo "winterfairy/tails".

#8 Updated by intrigeri about 6 years ago

  • Assignee changed from winterfairy to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to winterfairy:bugfix/ibus

#9 Updated by intrigeri about 6 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Merged in devel, pending for 0.22.

#10 Updated by intrigeri about 6 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF