Project

General

Profile

Feature #6175

Bug #7423: Have what we need included in Debian Jessie

Feature #5875: Make sure all the Python 3 libraries we need are in Jessie

List Python 3 libraries we need that are missing in Debian Jessie

Added by intrigeri about 6 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
07/19/2013
Due date:
08/31/2014
% Done:

100%

Feature Branch:
Type of work:
Research
Starter:
Yes
Affected tool:

Related issues

Related to Tails - Feature #5958: Port our custom software to Python 3 Confirmed 08/24/2015

History

#1 Updated by intrigeri about 6 years ago

  • Subject changed from List Python 3 libraries missing in Jessie to List Python 3 libraries we need that are missing in Jessie

#2 Updated by alant almost 6 years ago

  • Assignee set to alant

#3 Updated by alant almost 6 years ago

  • Status changed from Confirmed to In Progress

[was moved to the blueprint, deleting from here for clarity's sake.]

#4 Updated by alant almost 6 years ago

[was moved to the blueprint, deleting from here for clarity's sake.]

#5 Updated by intrigeri almost 6 years ago

Issue #6175 has been updated by alant.

Great work! How about using a blueprint to drop all this info?

Also the regexp above doesn't account for the from XXX import YYY form, so some dependencies may have been missed.

#6 Updated by alant almost 6 years ago

  • Blueprint set to https://tails.boum.org/blueprint/python3

Great work! How about using a blueprint to drop all this info?

Good idea, done.

Also the regexp above doesn't account for the from XXX import YYY form, so some dependencies may have been missed.

Yes I realized that later.

#7 Updated by BitingBird over 5 years ago

  • Due date set to 08/31/2014

Setting a limit date, because after that it's gonna be too late for Jessie :)

#8 Updated by BitingBird over 5 years ago

  • Target version set to Tails_2.0

#9 Updated by intrigeri about 5 years ago

  • Subject changed from List Python 3 libraries we need that are missing in Jessie to List Python 3 libraries we need that are missing in Debian Jessie
  • Target version deleted (Tails_2.0)
  • % Done changed from 0 to 10

#10 Updated by intrigeri about 5 years ago

  • % Done changed from 10 to 20

I've completed the list of what's obviously missing (on the blueprint). Left to do: find what libraries we'll replace the missing bits with, and check if they're in Debian.

#11 Updated by BitingBird about 5 years ago

  • Target version set to Tails_1.2.1

#12 Updated by alant about 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

Looked for compatibility of libraries that are missing in debian.

Short story:

- python3 supported upstream but not in debian: pycountry, configobj
- sould be replaced: GnuPGInterface →, gnutls → pygnutls

Also available in: Atom PDF