Project

General

Profile

Feature #6165

Improve visually the Contribute section

Added by bertagaz over 6 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
07/19/2013
Due date:
% Done:

100%

Feature Branch:
Type of work:
Website
Blueprint:
Starter:
No
Affected tool:

Description

They actually are hard to understand / read as it's designed as a big block without any differences between items and subitems. Possibly people this prevent people of reading this yet important part of the page.

This was decided during the "How to get more contributors" discussion at the 2013 summit.


Subtasks

Feature #6173: Group the links on top of the /contribute page by categoryResolved

Feature #6359: Write a short description for each contributor's roleResolved

Feature #6360: Choose a logo for each contribution roleResolved

Feature #6361: Create a stylesheet for the contributor's roleResolved

Bug #7047: Further simplify the links on the Contribute sessionRejected

Feature #6744: Add icons to contribute/talkRejected

History

#1 Updated by intrigeri about 6 years ago

  • Blueprint set to https://tails.boum.org/blueprint/contribute_section/
  • Starter set to No

#2 Updated by intrigeri about 6 years ago

  • Status changed from New to Confirmed

#3 Updated by intrigeri about 6 years ago

  • Status changed from Confirmed to Resolved

(closing by mistake)

#4 Updated by intrigeri about 6 years ago

  • Status changed from Resolved to Confirmed

#5 Updated by sajolida about 6 years ago

  • Status changed from Confirmed to In Progress
  • QA Check set to Ready for QA
  • Blueprint changed from https://tails.boum.org/blueprint/contribute_section/ to https://tails.boum.org/blueprint/contribute/

#6 Updated by intrigeri about 6 years ago

  • QA Check changed from Ready for QA to Dev Needed
  • Feature Branch set to doc/contribute-categories

See initial review on tails-dev.

#7 Updated by intrigeri about 6 years ago

  • Assignee set to sajolida

#8 Updated by intrigeri about 6 years ago

  • Assignee deleted (sajolida)
  • QA Check deleted (Dev Needed)

doc/contribute-categories merged, fixed and pushed.

#9 Updated by intrigeri about 6 years ago

  • Feature Branch deleted (doc/contribute-categories)

#10 Updated by sajolida almost 6 years ago

  • Subject changed from Better visibility of links on top of the /contribute page to Improve visually the Contribute section

#11 Updated by sajolida almost 6 years ago

  • Starter changed from No to Yes

#12 Updated by BitingBird almost 6 years ago

The title "Contribute with your technical skills" is too near from the upper section. Otherwise, I think this page looks very fine and should replace the existing one ASAP.

#13 Updated by BitingBird almost 6 years ago

Well, actually "technical skills" would be better named "computer skills" or "computing skills", since translations, writing etc are also technics, from another kind.

#14 Updated by sajolida almost 5 years ago

  • Target version set to 239

#15 Updated by sajolida almost 5 years ago

  • Target version deleted (239)

#16 Updated by BitingBird over 4 years ago

  • Blueprint deleted (https://tails.boum.org/blueprint/contribute/)

removing blueprint (has been merged)

#17 Updated by BitingBird over 4 years ago

  • Related to Bug #7047: Further simplify the links on the Contribute session added

#18 Updated by BitingBird over 4 years ago

  • Related to Feature #6169: Give examples explaining how to contribute added

#19 Updated by BitingBird over 4 years ago

#20 Updated by BitingBird over 4 years ago

  • Related to deleted (Bug #7047: Further simplify the links on the Contribute session)

#21 Updated by BitingBird over 4 years ago

  • Related to deleted (Feature #6169: Give examples explaining how to contribute)

#22 Updated by BitingBird over 4 years ago

  • Related to deleted (Feature #6744: Add icons to contribute/talk)

#23 Updated by BitingBird over 4 years ago

All child tickets had been resolved, so I wanted to suggest closing this ticket, but I added new children ticket on the topic instead :)

#24 Updated by BitingBird over 4 years ago

  • Starter changed from Yes to No

#25 Updated by Anonymous about 4 years ago

Are there any feature branches, etc., for this, or is it up to date w/ the current page on the site?

#26 Updated by sajolida about 4 years ago

Right now only the remaining child tickets are relevant. #7047 is probably too complex for newcomers but #6744 looks like an easy one if you want to learn a bit about how the internals our website work. To get started with working on the website, see the instructions we're working on in #9018. They're almost ready but are not published yet.

#27 Updated by u over 2 years ago

  • Assignee set to sajolida

Assigning parent ticket to sajolida who owns the only remaining subticket currently.

#28 Updated by sajolida over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

All subtickets are closed now :)

Also available in: Atom PDF