Project

General

Profile

Feature #6157

Feature #5663: Return to Icedove

Feature #6148: Torbirdy in Debian

Feature #6154: Secure the Icedove autoconfig wizard

Fix re-test in secure Icedove autoconfig wizard

Added by Tails almost 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Research
Blueprint:
Starter:
No
Affected tool:
Email Client

Description

research how to fix the "Re-test fails in the account creation wizard manual configuration window": Icedove ignores proxy settings, tries to connect to the Internet directly, and is forbidden to.


Related issues

Related to Tails - Feature #6369: Build Debian packages of Icedove 38 with our patches / create proper branch situation Resolved 10/16/2013

History

#1 Updated by intrigeri almost 6 years ago

  • Priority changed from Normal to High

#2 Updated by BitingBird almost 5 years ago

  • Subject changed from fix re-test in secure Icedove autoconfig wizard to Fix re-test in secure Icedove autoconfig wizard
  • Starter set to No

#3 Updated by sajolida almost 5 years ago

  • Priority changed from High to Normal

#4 Updated by intrigeri almost 5 years ago

  • Category set to 212

#5 Updated by BitingBird over 4 years ago

  • Related to Feature #6158: Fix secure Icedove autoconfig wizard in Tails added

#6 Updated by intrigeri over 4 years ago

  • Related to deleted (Feature #6158: Fix secure Icedove autoconfig wizard in Tails)

#7 Updated by intrigeri almost 4 years ago

  • Assignee set to kytv
  • Target version set to 246

#9 Updated by sajolida over 3 years ago

  • Target version changed from 246 to Tails_2.0

#10 Updated by u over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#11 Updated by u over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.0

This should actually be done for the release of 2.0 (without the need to be merged into 2.0) so that we can have a working PoC for 2.2.

#12 Updated by u over 3 years ago

  • Related to Feature #6369: Build Debian packages of Icedove 38 with our patches / create proper branch situation added

#13 Updated by kytv over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#14 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.0

I think I've mislead you somewhat early today, when I asked you to update your Icedove tickets. Sorry about that!

According to the timeline proposed on https://mailman.boum.org/pipermail/tails-icedove/2015-December/000108.html, we want a working PoC of the wizard ready during the 2.0 release cycle, so I think this ticket needs to stay on the 2.0 board for now.

Another option, which is rather what I was implicitly suggesting, would be to make it explicit (by creating new tickets) that the PoC is for 2.0, and that the goal is to have it merged for 2.2.

#15 Updated by u over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#16 Updated by u about 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#17 Updated by anonym about 3 years ago

Given the patch that adds SOCKS support to the guessing part of the automatic configuration, I think we are done here.

#18 Updated by anonym about 3 years ago

  • Assignee changed from kytv to anonym

#19 Updated by anonym about 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#21 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to In Progress

My understanding is that this has been fixed, and will be shipped to users as part of the branch for #6154. If I'm correct, then please close this ticket as resolved (it's a part of #6154, and it's not a bug that affects any released version of Tails, so no need to go through "Fix committed" :)

#22 Updated by anonym about 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (anonym)

#23 Updated by intrigeri almost 3 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF