Project

General

Profile

Bug #6092

Feature #9515: Improve test suite robustness vs transient network errors

Feature #8539: Make the test suite robust enough to be run as part of a CI setup

Tails Installer sometimes hangs late in the installation process

Added by Tails almost 6 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/6092-drop-racy-code
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Installer

Description

"Installing Tails to a pristine USB drive" often stalls with "Unmounting /dev/sda1" at 98%.

Still happens with 0.18~rc1, despite it has the commit fb3d08a5 from upstream liveusb-creator that we hoped would help.

log-screenshot-1.png View (110 KB) intrigeri, 01/11/2015 02:16 PM


Related issues

Related to Tails - Bug #6026: test suite: liveusb-creator hangs early Resolved

History

#1 Updated by intrigeri over 5 years ago

  • Category set to Test suite
  • Starter set to No

#2 Updated by intrigeri over 5 years ago

  • Parent task set to #5978

#3 Updated by intrigeri over 5 years ago

  • Tracker changed from Feature to Bug

#4 Updated by intrigeri over 5 years ago

  • Assignee set to bertagaz

I can't reproduce this. bertagaz, can you? Feel free to close if you can't.

#5 Updated by intrigeri about 5 years ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (bertagaz)
  • Target version set to Tails_0.23
  • % Done changed from 0 to 100

Neither anonym nor I can reproduce since the rjb branch was merged, so calling it resolved.

#6 Updated by anonym about 5 years ago

  • Status changed from Fix committed to Resolved

#7 Updated by intrigeri about 5 years ago

  • Status changed from Resolved to Confirmed
  • Target version deleted (Tails_0.23)
  • % Done changed from 100 to 50

I've seen this happen a few times in a row again. And then it stopped. Reopening.

#8 Updated by BitingBird almost 5 years ago

  • Subject changed from test suite: liveusb-creator hangs late to Test suite: liveusb-creator hangs late

#9 Updated by intrigeri almost 5 years ago

  • Parent task deleted (#5978)

#10 Updated by intrigeri almost 5 years ago

  • % Done changed from 50 to 0

I've been seeing it regularly recently, both on bare metal and in nested virtualization settings.

#11 Updated by intrigeri almost 5 years ago

  • Blocks Feature #5288: Run the test suite automatically on autobuilt ISOs added

#12 Updated by anonym over 4 years ago

  • Target version set to Hole in the Roof

#14 Updated by anonym over 4 years ago

  • Assignee set to intrigeri
  • QA Check set to Info Needed

Since I cannot reproduce this bug, could you try running usb_isntall.feature with --pause-on-fail until the bug triggers, then take over the VM and make a tarball of /var/log and all other debugging info you can think of and send it my way?

#15 Updated by sajolida over 4 years ago

  • Target version changed from Hole in the Roof to Sustainability_M1

#16 Updated by sajolida over 4 years ago

  • Target version changed from Sustainability_M1 to Tails_1.3

Set the target version to 1.3 (February 17) since this blocks #8117.

#17 Updated by sajolida over 4 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2

#18 Updated by intrigeri over 4 years ago

Commit 496e58cf ("Stop our progress thread before unmounting") might help. I'm not overly confident, but it's worth a try.

#19 Updated by intrigeri over 4 years ago

  • Blocks deleted (Feature #5288: Run the test suite automatically on autobuilt ISOs)

#20 Updated by intrigeri over 4 years ago

  • Parent task set to #8539

#24 Updated by BitingBird over 4 years ago

  • Affected tool set to Installer

#25 Updated by intrigeri over 4 years ago

intrigeri wrote:

Commit 496e58cf ("Stop our progress thread before unmounting") might help.

We already have this commit in our tree.

#26 Updated by intrigeri over 4 years ago

Reproduced, see attachment. Initial analysis: after copying and umounting, in gui.py around line 260, we do:

            if self.parent.opts.partition:
                self.rescan_devices()
                self.live.switch_back_to_full_drive()
                self.live.remove_hybrid_mbr()

rescan_devices calls self.live.detect_supported_drives, that itself defines handle_reply and uses it as a callback. And then, in handle_reply, this DBus call fails with the error message one can see on the screenshot:

                    data['parent'] = str(dbus.Interface(self._get_device(parent),
                            'org.freedesktop.DBus.Properties').Get(parent,
                                'DeviceFile'))

#27 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Tails_1.3.2 to Tails_1.3
  • % Done changed from 0 to 10
  • QA Check deleted (Info Needed)
  • Feature Branch set to liveusb-creator:bugfix/6092-drop-racy-code
  • Type of work changed from Research to Code

I have something that should hopefully fix it without breaking anything else. Let's see.

#28 Updated by intrigeri over 4 years ago

  • Priority changed from Normal to Elevated

Reproduced on isotester1.lizard in the same full test suite run, in the evince, totem and usb_install features => raising priority.

#29 Updated by intrigeri over 4 years ago

  • % Done changed from 10 to 20
  • Feature Branch changed from liveusb-creator:bugfix/6092-drop-racy-code to bugfix/6092-drop-racy-code

liveusb-creator .deb uploaded to bugfix-6092-drop-racy-code, merged into experimental. Now I'm going to run the test suite and see.

#30 Updated by intrigeri over 4 years ago

  • Subject changed from Test suite: liveusb-creator hangs late to Tails Installer sometimes hangs late in the installation process
  • Assignee deleted (intrigeri)
  • % Done changed from 20 to 50
  • QA Check set to Ready for QA

#31 Updated by alant over 4 years ago

  • Assignee set to alant

#32 Updated by alant over 4 years ago

  • Assignee changed from alant to intrigeri
  • QA Check changed from Ready for QA to Info Needed

I read the code, ticket and APT repository changes and I'm happy with them.

However, I wasn't able to reproduce the bug, so I only tested that this doesn't break the installer an obvious way. That part of the testsuite always fails for me.

Now I'm going to run the test suite and see.

I guess that marking the ticket as ready for QA means that the testsuite succeded for you? If it's the case, please feel free to merge.

#33 Updated by intrigeri over 4 years ago

I guess that marking the ticket as ready for QA means that the testsuite succeded for you?

Yes.

If it's the case, please feel free to merge.

Will do, thanks!

#34 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check changed from Info Needed to Pass

#35 Updated by intrigeri over 4 years ago

Merged.

#36 Updated by BitingBird about 4 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF