Project

General

Profile

Feature #6078

Freenet project

Added by Tails over 6 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Can you insert the freenet project for anon surfing in the next release?

<blockquote>

I doubt we do that this quick, patches are welcome! I suggest first checking how/if Freenet can be safely used with Tor.

<blockquote>

Persistence would almost be a requirement for Freenet, and it shouldn't have to go through Tor. The reason for needing persistence is because it takes literal days to get even 30 days worth of posts from services like Frost, more if you go farther back. It's bets to think of Freenet as a complex, distributed Usenet service (with the Frost program being the literal implementation). When first setting it up you specify the amount of data you wish to provide to the network, a few gigabytes worth by default, that's used as a cache to anonymously relay to other users upon request. Aside from relaying data to other users, the cache is also used to index the network for both local and relaying purposes. The bigger the cache the faster a local user's network is, otherwise it's painstakingly slow, and I couldn't fathom doing it from scratch from each Tails bootup.

adrelanos wrote: I considered combining Freenet with Tor for Whonix. Details: Whonix + Freenet Summary: There are probable three options using Freenet with tails.

<blockquote>

  1. Using an inproxy (gateway) to the Freenet network, I haven't found any which are still working.
  2. Connecting to Freenet through Tor. That is tricky, because Freenet does not support TCP and requires UDP and Tor only supports TCP and does not support UDP. A hackish workaround would be to tunnel a VPN through Tor, thus allowing UDP over Tor. I successfully tested it.
  3. Direct connections to Freenet and opt-in. Just like i2p support in Tails. Do it the same way as Tails + i2p. Tor and i2p can coexist in Tails, direct connections to both networks will be established. Why not opt-in to directly connect to Freenet? The question "if Freenet can be used safely through Tor" does not apply here. You also didn't ask "if i2p can be used safely through Tor".

<blockquote>

Freenet would work best connecting directly to the internet, much like i2p, and would be best as an opt-in system like i2p. Storing freenet in the persistent storage would be required due to freenet's design, and could allow freenets built-in update-over-freenet system to work well.

Freenet is worthwhile software to consider adding to tails in the medium or long term

</blockquote>

</blockquote>

</blockquote>

</blockquote>


Related issues

Duplicated by Tails - Feature #10168: Add Freenet? Duplicate 09/05/2015

History

#1 Updated by intrigeri over 6 years ago

  • Type of work set to Code

Type of work: Code

#2 Updated by BitingBird over 5 years ago

  • Subject changed from freenet project to Freenet project
  • Description updated (diff)
  • Starter set to No

#3 Updated by jvoisin almost 5 years ago

< nextgens> jvoisin> 1) is a terrible idea for obvious reasons, 2) is a worse idea, 3) is definitely the way to do it
< nextgens> jvoisin> whether it's a good idea to have Freenet on a liveCD I'm not sure; but heh
< nextgens> jvoisin> some people think it is
< nextgens> jvoisin> let me know if you want me to elaborate on the above

nextgens is one of the freenet developers.

#4 Updated by kytv over 4 years ago

#5 Updated by elypter about 4 years ago

maybe try to inlude it in whonix first. it is not a live cd.

#6 Updated by londonsilver almost 4 years ago

freenet needs an as-constantly-as-possible running service and a data store of at least a few GB.
IMO definitely nothing Tails is designed for. It would, just for instance, allure users to leave Tails running unattended for days/weeks with unlocked persistence (at least some of that time unattended).

We could integrate freenet clients though (FMS, Frost, ...) to connect to a locally running freenet server (that can be as tiny as an RBPi).

#7 Updated by BitingBird over 3 years ago

Is any of those clients in Debian? Which one would you recommend ?

#8 Updated by jvoisin over 3 years ago

This looks like a specific niche usecase to me, is it really worth integrating it in Tails?

#9 Updated by cypherpunks over 3 years ago

I don't think it's worth integrating. People can already just set up Freenet on a server or on their LAN on another computer, and connect to it through Tails. And obviously as londonsilver explained, you pretty much can't run Freenet itself on Tails due to it needing to run 24/7 in order to function properly, or at all.

#10 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Rejected

Given the input we had here, it's unclear that running Freenet from Tails would be a good idea at all, so I'm rejecting this ticket. Whoever wants to see this happen, please start via "Additional software packages", work on the integration and explain why it's a good idea to make it possible to run Freenet in Tails.

Also available in: Atom PDF