Project

General

Profile

Feature #6056

Refactor Puppet code for Jenkins

Added by Tails over 6 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
-
Start date:
04/17/2014
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
No
Affected tool:

Description

Factor out Jenkins setup code from the {jenkins,builder,www,...}.lizard node definitions to a set of tails:: Puppet modules.


Subtasks

Feature #7105: Refactor Puppet code for the Jenkins masterResolvedintrigeri

Feature #7106: Refactor Puppet code for the Jenkins slave on builder.lizardResolved

Feature #7107: Refactor Puppet code for Jenkins from www.lizardResolved

Feature #6132: Automated tests using cucumberResolved


Related issues

Related to Tails - Feature #6181: Make it possible to help with sysadmin Resolved 07/23/2013

History

#1 Updated by Tails over 6 years ago

  • Parent task set to #5324

#2 Updated by bertagaz over 6 years ago

  • Assignee set to bertagaz

#3 Updated by sajolida almost 6 years ago

  • Subject changed from refactor Puppet code for Jenkins to Refactor Puppet code for Jenkins
  • Starter set to No

#4 Updated by intrigeri over 5 years ago

Split into 3 sub-tickets, so that I could clearly indicate that I've just done a part of this work. Assigned remaining sub-tasks to bertagaz, since he assigned the parent ticket to himself :)

#5 Updated by intrigeri almost 5 years ago

  • Target version changed from Sustainability_M1 to Tails_1.4

#6 Updated by bertagaz almost 5 years ago

  • Target version changed from Tails_1.4 to Tails_1.3

#7 Updated by bertagaz over 4 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2

Postponing.

#8 Updated by bertagaz over 4 years ago

  • Target version changed from Tails_1.3.2 to Tails_1.4

#9 Updated by intrigeri over 4 years ago

  • Target version changed from Tails_1.4 to Tails_1.4.1

Postponing.

#11 Updated by intrigeri over 4 years ago

I see that all subtasks have been completed. Any reason to keep this ticket open? Now would be a good time to take a step back and see if we've reached our short-term goals in this area.

#12 Updated by bertagaz over 4 years ago

  • Assignee changed from bertagaz to intrigeri

I think we do, the manifests related to Jenkins now look better. We might still want to refactor the NFS bits of nightly.t.b.o, but that's another ticket.

Feel free to close it if you agree.

#13 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • QA Check set to Pass

#14 Updated by sajolida over 4 years ago

  • Status changed from Resolved to Confirmed
  • Target version deleted (Tails_1.4.1)

#15 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to Resolved

Also available in: Atom PDF