Project

General

Profile

Feature #6018

Explain why Tails ships Tor

Added by Tails about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
doc/why_tor
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

Explain why Tails ships Tor vs. other $ANONYMIZING_SOFTWARE. Somewhere: contributors FAQ? users FAQ? design doc?

Late 2012, we explained AdvOR drawbacks on the forum:

<blockquote>

AdvOR was forked from mainline Tor around three years ago. Given how its sources are published (just a .zip, no source control AFAICT) it's very hard to follow up on any changes it introduces, and any (important) changes from mainline Tor it does not include. There's little (none?) documentation either.

This and the author's complete absense in the Tor community are some pretty strong warning signs, IMHO. Not to mention that any difference in behaviour from mainline Tor will put AdvOR users into their own relatively tiny partition of \"Tor\" users, which sucks for anonymity. Also see Nick Mathewson's (Tor's Chief Architect) analysis for some enlightenment.

</blockquote>

History

#1 Updated by intrigeri about 6 years ago

  • Starter set to No

https://www.torproject.org/docs/faq.html probably has some bits that could be valuable here.

#2 Updated by intrigeri almost 6 years ago

  • Assignee set to sajolida

#3 Updated by intrigeri over 5 years ago

  • Subject changed from explain why Tails ships Tor to Explain why Tails ships Tor

#4 Updated by sajolida over 5 years ago

  • Assignee:

Actually, this has been lying around for years because I'm not inspired
at all by that.

Does someone still feels like this is really important? Is it still
relevant to compare to AdvOR?

If someone finds that important, please provides some relevant hints at
what would such a documentation explain.

#5 Updated by BitingBird over 5 years ago

I don't see the interest, nobody ever asked about AdvOR on the chan when i was there. Sounds like it's not "in" anymore. I think this ticket could be closed, and a new one opened when the need arises again.

#6 Updated by intrigeri over 5 years ago

Does someone still feels like this is really important?

Quite.

Is it still relevant to compare to AdvOR?

Probably not.

If someone finds that important, please provides some relevant hints at
what would such a documentation explain.

Tor is the best low-latency anonymity solution these days:

  • VPNs are out, as don't provide strong anonymity
  • Tor benefits from the most academic research
  • Tor benefits from the most auditing and peer review
  • Tor has the largest share of users, so simply "using Tor" is not
    tooooo identifying

#7 Updated by sajolida over 5 years ago

  • QA Check set to Ready for QA
  • Feature Branch set to doc/why_tor

#8 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50
  • QA Check changed from Ready for QA to Dev Needed

Almost there! See comments on tails-dev.

#9 Updated by anonym over 5 years ago

  • Target version changed from Tails_1.0 to Tails_1.1

#10 Updated by sajolida over 5 years ago

  • QA Check changed from Dev Needed to Ready for QA

#11 Updated by intrigeri over 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • Target version changed from Tails_1.1 to Tails_1.0
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF