Project

General

Profile

Feature #6017

Feature #5684: Screen locker

Ensure that the emergency shutdown works while the screen is locked

Added by Tails over 6 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

The following sentence might pretend that the locked screen interacts badly with the emergency shutdown:

"When the screen is locked, it's not possible to quickly shutdown the computer properly (i.e. with memory erasure): the computer's shutdown button is inhibited, and the fact to put out Tails' device does not shut the computer down."

History

#1 Updated by Tails over 6 years ago

  • Parent task set to #5684

#2 Updated by intrigeri over 6 years ago

  • Priority changed from Normal to Elevated

#3 Updated by BitingBird over 5 years ago

  • Subject changed from ensure that the emergency shutdown works while the screen is locked to Ensure that the emergency shutdown works while the screen is locked
  • Starter set to No

#4 Updated by BitingBird over 4 years ago

  • Target version set to 2017

Same milestone as parent ticket

#5 Updated by intrigeri about 4 years ago

sajolida says "I tested that and it works on Tails Jessie" so I think we can close this ticket.

#6 Updated by sajolida about 4 years ago

  • Status changed from Confirmed to Resolved

Yeah!

#7 Updated by intrigeri over 3 years ago

  • Status changed from Resolved to In Progress
  • Assignee set to segfault

#7334#note-13 says that this does not work. segfault, can you please have a look?

#8 Updated by segfault over 3 years ago

  • Type of work changed from Test to Code

Unplugging the device works. But the power button does indeed not work in the lockscreen. Is this a blocker? I could not find out how to get signalled that the power button was pressed. There are some related signals on dbus from systemd-logind, but nothing we could use for this. Maybe someone who knows this already could explain how the emergency shutdown gets triggered by the power button currently? anonym maybe?

#9 Updated by segfault over 3 years ago

  • Assignee changed from segfault to anonym

#10 Updated by sajolida over 3 years ago

I don't think that's a blocker.

#11 Updated by sajolida over 3 years ago

  • Target version changed from 2017 to Tails_2.6
  • QA Check set to Info Needed

Marking this as "Info Needed" because I understand that you assigned it to anonym for more info (and not for coding). Also putting it for 2.6, to get a quicker answer.

#12 Updated by intrigeri over 3 years ago

I don't think that's a blocker.

Agreed.

#13 Updated by intrigeri over 3 years ago

  • Assignee changed from anonym to segfault
  • QA Check deleted (Info Needed)

First of all, what we call "emergency shutdown" is the one triggered by plugging the boot device out. What is triggered by the power button is normal shutdown. I'm pretty sure it's handled by systemd-logind.

#14 Updated by sajolida over 3 years ago

I think that triggering nothing when pressing the power button while the screen is locked is no problem. So maybe this is Ready for QA?

#15 Updated by sajolida over 3 years ago

  • QA Check set to Info Needed

segfault: So maybe we can close this?

#16 Updated by segfault over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (segfault)
  • QA Check deleted (Info Needed)

segfault: So maybe we can close this?

If the "emergency shutdown" is only the one triggered by unplugging the boot device, this is solved and can be closed. (I wonder why this ticket was reopened in the first place, because #7334#note-13 is only about the power button not working)

Also available in: Atom PDF