Project

General

Profile

Feature #5987

Distribute source

Added by Tails about 6 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Infrastructure
Target version:
-
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

We need to distribute the source of what we ship inside Tails binary images, which basically means:

  • the source for included Debian packages
  • the source for Debian packages that are used at build-time to compile binary files, but not shipped inside the chroot (e.g. some -dkms packages, probably)

Roadmap

  1. offer to provide source upon request (#5681)
  2. On the long run, we probably want something better. We must decide what path we choose.
    1. research ways to distribute source (#5548)

Subtasks

Feature #5548: Research ways to distribute sourceResolved

Feature #5681: Offer to provide the source of packages included in Tails upon requestResolved


Related issues

Related to Tails - Feature #5926: Freezable APT repository Resolved 09/26/2013
Related to Tails - Feature #6310: Publish source Debian packages used by Tails ISO images Resolved 09/26/2013
Related to Tails - Feature #6311: Document how to get the source code of packages shipped in Tails Resolved 09/26/2013

History

#1 Updated by Tails about 6 years ago

  • Priority changed from High to Normal

#2 Updated by Tails about 6 years ago

  • Priority changed from High to Normal

#3 Updated by Tails about 6 years ago

  • Priority changed from High to Normal

#4 Updated by intrigeri about 6 years ago

  • Type of work set to Sysadmin

Type of work: Sysadmin

#5 Updated by intrigeri almost 6 years ago

  • Category set to Infrastructure
  • Starter set to No

#6 Updated by BitingBird about 5 years ago

  • Subject changed from distribute source to Distribute source

#7 Updated by intrigeri over 3 years ago

  • Assignee set to intrigeri
  • Target version changed from Hole in the Roof to Tails_2.5
  • Type of work changed from Sysadmin to End-user documentation

Once 2.4 is out, we will be distributing the source code of Debian packages we ship (e.g. http://tagged.snapshots.deb.tails.boum.org/2.4-rc1/) so everything that'll left to do is to document this. I'll do that!

#8 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (intrigeri)
  • Target version deleted (Tails_2.5)

Actually, this seems to be a duplicate of #6310 + #6311.

Also available in: Atom PDF