Project

General

Profile

Feature #5979

Persistence preset: mouse and touchpad settings

Added by Tails over 5 years ago. Updated 5 months ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
Persistence
Target version:
-
Start date:
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Everytime booting Tail, I have to set up the Mouse Settings to allow Mouseclicks on the Touchpad.

Would be nice if it would be possible to make System Settings like this persistent. thanks


Related issues

Related to Tails - Feature #7779: Revisit default touchpad settings Resolved 08/13/2014
Duplicated by Tails - Feature #5989: Persistence preset - mouse settings Duplicate

History

#1 Updated by intrigeri over 5 years ago

  • Type of work set to Code

Type of work: Code

#2 Updated by intrigeri about 5 years ago

  • Subject changed from Persistence: Allow the option to make "Touchpad Settings" persistent to persistence preset: touchpad settings
  • Category set to Persistence
  • Starter set to No

#3 Updated by BitingBird over 4 years ago

  • Subject changed from persistence preset: touchpad settings to Persistence preset: touchpad settings

#4 Updated by sajolida over 4 years ago

  • Related to Feature #5989: Persistence preset - mouse settings added

#5 Updated by intrigeri over 4 years ago

  • Subject changed from Persistence preset: touchpad settings to Persistence preset: mouse and touchpad settings

#6 Updated by intrigeri over 4 years ago

  • Related to deleted (Feature #5989: Persistence preset - mouse settings)

#7 Updated by intrigeri over 4 years ago

  • Duplicated by Feature #5989: Persistence preset - mouse settings added

#8 Updated by intrigeri over 4 years ago

  • Related to Feature #7779: Revisit default touchpad settings added

#9 Updated by emmapeel over 3 years ago

  • Related to Feature #8846: Persistent preset: background option added

#10 Updated by intrigeri over 3 years ago

  • Related to deleted (Feature #8846: Persistent preset: background option)

#11 Updated by u 10 months ago

  • Status changed from Confirmed to Rejected

Is this still the case, that by default the touchpad is not accepting taps?
I think we should reject this ticket, because we decided at some point to rely on defautl GNOME settings for this. If you disagree, don't hesitate to reopen this.

#12 Updated by intrigeri 10 months ago

  • Status changed from Rejected to Confirmed

I think we should reject this ticket, because we decided at some point to rely on defautl GNOME settings for this. If you disagree, don't hesitate to reopen this.

I disagree. Touchpad settings (tap-to-click, scrolling direction etc.) is about muscle memory and not something we can ask users to just deal with our default settings: e.g. natural scrolling is a burden for those who are used to the opposite; it's the default on Windows so we're not talking about a corner case here. So it would be nice to give the option to persistently configure this differently.

#13 Updated by triceps1 5 months ago

I think we should reject this ticket, because we decided at some point to rely on defautl GNOME settings for this. If you disagree, don't hesitate to reopen this.

I disagree. Touchpad settings (tap-to-click, scrolling direction etc.) is about muscle memory and not something we can ask users to just deal with our default settings: e.g. natural scrolling is a burden for those who are used to the opposite; it's the default on Windows so we're not talking about a corner case here. So it would be nice to give the option to persistently configure this differently.

I also disagree with the rejection of this ticket.

It is a massive pain if i start running my persistant Tails and thinks work can start right now and then i be hurtly remindet that I have to chage various Gnome settings every time i start Tails.
So i have to disable the horrible 'natural scrolling' and as a MacBook user without physically buttons on my touchpad, I have to struggle around with the 'tap-to-click' function and the unavailible secondary button on my touchpad (right click on the touchpad bottom).

After set up my Gnome settings every time once again, it's frustrating enough that the Apple specific buttons alt/option (⌥) & cmd (⌘) have a total different meaning in Linux/Tails.
My workflow get destroyed every few minutes.

It would be super nice if you could make the Gnome settings saved persistently.
At least you could integrate a script generator, so that every user could generate his very own gnome settings script whom will be saved in the persistent folder and could be started manually after every persistent boot.

#14 Updated by intrigeri 5 months ago

It would be super nice if you could make the Gnome settings saved persistently.
At least you could integrate a script generator, so that every user could generate
his very own gnome settings script whom will be saved in the persistent folder and
could be started manually after every persistent boot.

Personally I have a persistent script that I run after login and that contains a bunch of dconf commands, which seems pretty close to what you're asking for. Now, of course this requires finding out the name of dconf settings and fiddling with command line interfaces so it'll only work for somewhat-technical users.

#15 Updated by triceps1 5 months ago

Now, of course this requires finding out the name of dconf settings and fiddling with command line interfaces so it'll only work for somewhat-technical users.

Considering the usability and design goals of tails i agree that it makes no sense to solve the problem of non-persistent configurations on this way. But i still think it's worth resolving this problem because it makes tails unhandy in a serious way.

Personally I have a persistent script that I run after login and that contains a bunch of dconf commands, which seems pretty close to what you're asking for.

Can you explain your script/workaround for my personal use?
I never worked with dconf and my bash scripting skills are low level.

At least i found the file including the Xorg defaults:

/usr/share/X11/xorg.conf.d/90-tails.conf
Section "InputClass" 
    Identifier "Tails-touchpad-configuration" 
    MatchIsTouchpad "on" 
    Option "TapButton1" "1" 
    Option "VertTwoFingerScroll" "1" 
EndSection

I also know what parameters I need to change:

Option "TapButton1" "0"
Option "VertTwoFingerScroll" "0"

What I need to know is which dconf commands I need to change these parameters?

Also available in: Atom PDF