Project

General

Profile

Bug #5967

Tails OpenPGP applet should not empty the clipboard after a bad decryption passphrase was entered

Added by Tails about 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
OpenPGP Applet

Description

Initial bug report

When decrypting a text encrypted using passphrase encryption with Tails gpgApplet, if you enter a wrong passphrase you have to copy the text again to try another passphrase. The encrypted text should be kept in the clipboard even if the given passphrase is wrong.

Bug description

Investigating this bug, I found that the issue is that gpgApplet recieves "owner-change" signal on X clipboard, with an empty clipboard content each time it is called. It used to update freshest clipboard as a consequence, thus not accessing the encrypted data anymore.

1st fix

In bugfix/gpgapplet_do_not_erase_clipboard now update the clipboard only if it is not empty. This keeps the content of the CLIPBOARD clipboard. Shipped in Tails 0.19.

Left to do

The X clipboard is still filled with empty data, replacing its old content. If it was the X clipboard that contained the data to be decrypted, the initial bug report would still apply.


Related issues

Blocked by Tails - Feature #7711: Port the OpenPGP applet to GTK+ 3 Resolved 08/01/2014

History

#1 Updated by intrigeri about 5 years ago

  • Tracker changed from Feature to Bug
  • Subject changed from gpgapplet: do not erase clipboard after bad passphrase to Tails OpenPGP applet should not empty the clipboard after a bad decryption passphrase was entered
  • Description updated (diff)
  • Starter set to No

#2 Updated by BitingBird over 4 years ago

  • Affected tool set to OpenPGP Applet

#3 Updated by nodens almost 3 years ago

  • Status changed from Confirmed to Fix committed
  • Assignee set to nodens

From my tests, this is fixed with the merging of feature/7711-gtk3. At least I couldn't reproduce it.

#4 Updated by nodens almost 3 years ago

  • Related to Feature #7711: Port the OpenPGP applet to GTK+ 3 added

#5 Updated by nodens almost 3 years ago

  • Related to deleted (Feature #7711: Port the OpenPGP applet to GTK+ 3)

#6 Updated by nodens almost 3 years ago

  • Blocked by Feature #7711: Port the OpenPGP applet to GTK+ 3 added

#7 Updated by intrigeri almost 3 years ago

  • Target version set to Tails_2.9.1

#8 Updated by intrigeri almost 3 years ago

  • Status changed from Fix committed to Resolved
  • Assignee deleted (nodens)
  • Target version deleted (Tails_2.9.1)

It was uploaded to sid :)

Also available in: Atom PDF