Project

General

Profile

Feature #5962

Set default dictionary according to locale in the browser

Added by Tails about 6 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Internationalization
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Browser

Description

The fix for fix default iceweasel spelling language (#5371) (using the amnesia branding extension so that it sets the preferred dictionary according to the current locale) does not really work that well. For most languages we testing on 0.17~rc1, no dictionary was selected by default. English had one, though.


Related issues

Related to Tails - Feature #9021: Consider including more dictionaries Rejected 03/06/2015
Related to Tails - Feature #10272: Test that the default spellcheck language matches the language selected at the greeter Rejected 09/26/2015
Related to Tails - Feature #15807: Define & apply clear criteria for including dictionaries, fonts and language packs Resolved 08/18/2018
Related to Tails - Bug #16571: Tor Browser does not list spell checker dictionaries installed via APT In Progress 03/18/2019
Duplicated by Tails - Bug #6587: Iceweasel spelling dictionnary sould be localized for all languages supportedg Duplicate 01/09/2014

Associated revisions

Revision 4108e9af (diff)
Added by intrigeri about 3 years ago

Manual test suite: drop test for feature we haven't had for 3+ years.

refs: #10272, #5962

History

#1 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to Resolved
  • Type of work changed from Test to Code
  • Starter set to No

In some pre-0.21 dev snapshot: German, French, Spanish and Italian have the right dictionary selected. Stopping my tests here, and calling it resolved.

#2 Updated by intrigeri almost 6 years ago

  • Status changed from Resolved to Confirmed

In 0.22 tentative ISO, it works for Spanish, French and Portuguese; but it doesn't work in "most" (?) languages including English. Reopening.

#3 Updated by intrigeri almost 6 years ago

  • Subject changed from select localized spelling dictionary in Iceweasel to Select localized spelling dictionary in Iceweasel

#4 Updated by intrigeri almost 6 years ago

  • Category set to 176

#5 Updated by sajolida over 5 years ago

  • Priority changed from Normal to Low

#6 Updated by sajolida over 5 years ago

Testing in 0.23, doesn't work for Spanish. Seems like this degrades over time...

#7 Updated by sajolida over 5 years ago

  • Subject changed from Select localized spelling dictionary in Iceweasel to Set default dictionary according to locale in the browser

#8 Updated by BitingBird about 5 years ago

  • Duplicated by Bug #6587: Iceweasel spelling dictionnary sould be localized for all languages supportedg added

#9 Updated by BitingBird over 4 years ago

  • Category set to Internationalization

#10 Updated by BitingBird over 4 years ago

  • Related to Feature #9021: Consider including more dictionaries added

#11 Updated by kytv almost 4 years ago

  • Blocks Feature #10272: Test that the default spellcheck language matches the language selected at the greeter added

#12 Updated by intrigeri about 3 years ago

  • Blocks deleted (Feature #10272: Test that the default spellcheck language matches the language selected at the greeter)

#13 Updated by intrigeri about 3 years ago

  • Related to Feature #10272: Test that the default spellcheck language matches the language selected at the greeter added

#14 Updated by intrigeri about 1 year ago

Note that Firefox (and thus Tor Browser) seems to use the language of the web page to set the dictionary: for example, on our website, when editing a blueprints it will always set the spellchecking language to English by default, regardless of the locale. I suspect this explains a great lot of the conflicting reports seen above.

#15 Updated by u about 1 year ago

  • Related to Feature #15807: Define & apply clear criteria for including dictionaries, fonts and language packs added

#16 Updated by intrigeri 6 months ago

  • Related to Bug #16571: Tor Browser does not list spell checker dictionaries installed via APT added

#17 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to Rejected

intrigeri wrote:

Note that Firefox (and thus Tor Browser) seems to use the language of the web page to set the dictionary: for example, on our website, when editing a blueprints it will always set the spellchecking language to English by default, regardless of the locale.

This seems to be the intended and desired behavior to me ⇒ rejected as "it's a feature, not a bug". If someone strongly disagrees, I think this would be better addressed upstream.

Also available in: Atom PDF