Project

General

Profile

Feature #5917

Feature #5464: Revamp Greeter interface

Feature #8230: Greeter revamp: Phase 1

tails-greeter password field : Warn when caps-lock is ON

Added by Tails over 6 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Greeter

Description

The password field when activating the persistence and when setting the root password should give a warning when Caps Lock is ON.

This warning could be the same as used when unlocking an encrypted device.

History

#1 Updated by intrigeri over 6 years ago

  • Category set to 165

#2 Updated by intrigeri over 6 years ago

  • Starter set to Yes

#3 Updated by intrigeri almost 6 years ago

  • % Done changed from 0 to 10

A preliminary patch was posted on the "[Tails-dev] Fix to #5917 tails-greeter password field : Warn when caps-lock in ON" thread. Problems with it are discussed there:

https://mailman.boum.org/pipermail/tails-dev/2013-November/004024.html

#4 Updated by kurono over 5 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to kurono

#5 Updated by BitingBird over 5 years ago

  • Subject changed from tails-greeter password field : Warn when caps-lock in ON to Tails-greeter password field : Warn when caps-lock in ON

#6 Updated by BitingBird over 5 years ago

  • Subject changed from Tails-greeter password field : Warn when caps-lock in ON to tails-greeter password field : Warn when caps-lock is ON

#7 Updated by BitingBird over 5 years ago

  • Related to Feature #5594: tails-greeter: better administration password UI added

#8 Updated by intrigeri almost 5 years ago

  • Related to deleted (Feature #5594: tails-greeter: better administration password UI)

#9 Updated by intrigeri almost 5 years ago

  • QA Check set to Dev Needed

#10 Updated by intrigeri almost 5 years ago

  • Priority changed from Elevated to High
  • Parent task set to #5464

#11 Updated by intrigeri almost 5 years ago

  • Related to Feature #5594: tails-greeter: better administration password UI added

#12 Updated by BitingBird over 4 years ago

Any news on this? The priority is elevated, and it's in progress since a year but doesn't have a target version...

#13 Updated by kurono about 4 years ago

  • Assignee changed from kurono to alant
  • Starter changed from Yes to No

Beyond what I have already done in:
https://mailman.boum.org/pipermail/tails-dev/2013-November/004024.html,
I don't have a clue. Somebody with more experience with GTK? Alant?

#14 Updated by alant over 3 years ago

  • Parent task changed from #5464 to #8230

#15 Updated by alant over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (alant)
  • % Done changed from 10 to 100
  • QA Check changed from Dev Needed to Pass

#16 Updated by alant almost 3 years ago

  • Related to deleted (Feature #5594: tails-greeter: better administration password UI)

Also available in: Atom PDF