Project

General

Profile

Bug #5897

Feature #5978: test suite: usb install feature

test suite: usb install feature fails at shutdown time

Added by Tails over 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
No
Affected tool:

Description

I see:

And Tails is running from USB drive "current"                      # features/step_definitions/usb.rb:305
And the boot device has safe access rights                         # features/step_definitions/usb.rb:322
And I enable persistence with password "asdf"                      # features/step_definitions/usb.rb:248
And I log in to a new session                                      # features/step_definitions/common_steps.rb:165
And GNOME has started                                              # features/step_definitions/common_steps.rb:204
And I have closed all annoying notifications                       # features/step_definitions/common_steps.rb:254
And persistence has been enabled                                   # features/step_definitions/usb.rb:277
And I write some files expected to persist                         # features/step_definitions/usb.rb:354
And I completely shutdown Tails                                    # features/step_definitions/common_steps.rb:402
  The image 'TailsEmergencyShutdownHalt.png' did not match in this region. (Sikuli::ImageNotFound)
  ./features/support/helpers/sikuli_helper.rb:31:in `wait_and_click'
  ./features/step_definitions/common_steps.rb:407:in `(root)':in `/^I completely shutdown Tails$/'
  features/usb_install.feature:86:in `And I completely shutdown Tails'
Scenario failed at time 00:46:52

And:

And the boot device has safe access rights                         # features/step_definitions/usb.rb:322
And I enable read-only persistence with password "asdf"            # features/step_definitions/usb.rb:271
And I log in to a new session                                      # features/step_definitions/common_steps.rb:165
And GNOME has started                                              # features/step_definitions/common_steps.rb:204
And I have closed all annoying notifications                       # features/step_definitions/common_steps.rb:254
And persistence has been enabled                                   # features/step_definitions/usb.rb:277
And I write some files not expected to persist                     # features/step_definitions/usb.rb:371
And I remove some files expected to persist                        # features/step_definitions/usb.rb:363
And I completely shutdown Tails                                    # features/step_definitions/common_steps.rb:402
  The image 'TailsEmergencyShutdownHalt.png' did not match in this region. (Sikuli::ImageNotFound)
  ./features/support/helpers/sikuli_helper.rb:31:in `wait_and_click'
  ./features/step_definitions/common_steps.rb:407:in `(root)':in `/^I completely shutdown Tails$/'
  features/usb_install.feature:104:in `And I completely shutdown Tails'
Then only the expected files should persist on USB drive "current" # features/step_definitions/usb.rb:390
Scenario failed at time 00:56:00

Screenshots show a black screen.

History

#1 Updated by intrigeri about 6 years ago

  • Category set to Test suite
  • Starter set to No

#2 Updated by intrigeri almost 6 years ago

  • Tracker changed from Feature to Bug
  • Parent task set to #5978

#3 Updated by intrigeri almost 6 years ago

  • Assignee set to bertagaz
  • Type of work changed from Research to Test

I can't reproduce this on bare metal (test/rjb-migration branch, today's build from devel).

Can anyone reproduce this? Reassigning to bertagaz, who is running this in a nested setup.

#4 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to 11
  • Assignee deleted (bertagaz)
  • % Done changed from 0 to 100

Neither anonym nor I can reproduce since the rjb branch was merged, so calling it resolved.

#5 Updated by intrigeri almost 6 years ago

  • Target version set to Tails_0.23

#6 Updated by anonym over 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF