Project

General

Profile

Feature #5891

Feature #6015: Tails based on Wheezy

wheezy: list newly installed packages

Added by Tails about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

List newly installed packages. Then, we can decide to remove some.


Related issues

Related to Tails - Feature #5577: wheezy: remove various unneeded packages Resolved

Associated revisions

Revision 1556e34f (diff)
Added by Tails developers over 5 years ago

Remove more unwanted package (Closes: #5891).

History

#1 Updated by Tails about 6 years ago

  • Parent task set to #6015

#2 Updated by intrigeri almost 6 years ago

  • Starter set to No

#3 Updated by intrigeri almost 6 years ago

  • Assignee set to intrigeri

#4 Updated by intrigeri almost 6 years ago

  • Target version set to Tails_1.1

#5 Updated by intrigeri over 5 years ago

New packages (comparing Tails 0.22 and a 20131119 build of feature/wheezy, ignoring so version bumps and some obvious packages):

Keep

  • accountsservice: now needed by the greeter
  • apg: gnome-control-center Depends apg
  • bookletimposer: added by us
  • cheese-common, libcheese*: transitive deps of gnome-control-center
  • cryptsetup-bin: split package
  • cups-filters: cups Depends cups-filters
  • dconf-gsettings-backend, dconf-service, dconf-tools: deps of GNOME
  • fonts-*: renamed packages
  • fuse: required by sshfs, renamed from fuse-utils
  • gconf-service: sound-juicer Depends gconf-service
  • gcr: seahorse Depends gcr
  • gir1.2-*: dependendies of various parts of GNOME
  • git-man: split package, we want to ship the help
  • glib-networking*: dependencies of GNOME
  • gnome-*-data: bits of GNOME
  • gnome-icon-theme-symbolic: needed by GNOME
  • gnome-session-fallback
  • gnome-themes-standard: added by us
  • gsettings-desktop-schemas: needed by GNOME
  • gstreamer0.10-nice: needed by Pidgin
  • gstreamer0.10-pulseaudio, gstreamer0.10-x: well, we want audio and video
  • gvfs-daemons: split package
  • imagemagick-common: required by inkscape
  • kmod: dependency of the kernel
  • libamd2.2.0: needed by Gimp
  • libanty0: needed by ibus-anthy
  • libao*: needed by orca
  • libapt*: needed by Synaptic and APT
  • libasprintf0c2: needed by gettext and poedit
  • libassuan0: needed by gnupg-agent
  • libatk*: needed by bits of GNOME
  • libbluray1: needed by bits of GNOME
  • libcairo-gobject2
  • libcap2-bin: needed by Seahorse
  • libclutter*: needed by bits of GNOME
  • libcogl*: needed by bits of GNOME
  • libcmis-0.2-0: needed by LibreOffice
  • libcolord1: needed by bits of GNOME
  • libdotconf1.0: needed by orca
  • libevview3-3: needed by Evince
  • libexttextcat*: needed by LibreOffice
  • libfarstream-0.1-0: needed by Pidgin
  • libfftw3-3: needed by GNOME and Pidgin
  • libfile-listing-perl: needed by various Perl libs we need
  • libgd2-xpm: needed by Simple Scan
  • libgeoclue0: needed by GNOME
  • libgettextpo0: needed by gettext
  • libgoa*: needed by GNOME
  • libgxps2: needed by Evince
  • libhttp-*: split package
  • libio-socket-inet6-perl: needed by Net::Server and thus msva-perl
  • liblvm2app2.2: needed by GNOME
  • liblwp-protocol-https-perl: needed by our Perl stuff
  • libmath-bigint-perl: needed by msva-perl
  • libmath-round-perl: transitively needed by our Perl stuff
  • libmhash2: needed by LibreOffice
  • libmoosex-role-parameterized-perl: needed by our Perl stuff
  • libmount1: needed by... mount
  • libmp3lame0: needed by audacity and many more
  • libmpc2: needed by GDM
  • libmtdev1: needed by xserver-xorg-input-synaptics
  • libmx*: needed by GNOME
  • libnettle4: needed by GNOME
  • liboauth0: needed by totem-plugins
  • libopenal*: needed by GNOME and Pidgin
  • libopencc1: needed by ibus-pinyin
  • libopus0: needed by GNOME and Pidgin
  • libpackagekit-glib2-14: needed by GNOME
  • libpipeline1: needed by Yelp
  • libpodofo0.9.0: needed by Scribus
  • libportsmf0: needed by Audacity
  • libquvi*: needed by Totem
  • librest-0.7-0: needed by GNOME
  • librtmp0: needed by GNOME
  • libsbsms10: needed by Audacity
  • libsocialweb*: needed by GNOME
  • libspandsp2: needed by GNOME
  • libspeechd2: needed by orca
  • libsystemd-*: needed by GNOME
  • libtelepathy-glib0: needed by GNOME
  • libtracker-sparql-0.14-0: needed by GNOME
  • libumfpack5.4.0: needed by Gimp
  • libustr-1.0-1: needed by passwd
  • libva1: needed by gstreamer0.10-ffmpeg
  • libvisio-0.0-0: needed by LibreOffice
  • libvo-*: needed by GNOME and Pidgin
  • libwacom*: needed by GNOME
  • libwebrtc-audio-processing-0: needed by PulseAudio
  • libzvbi0: needed by GNOME
  • lua-socket: needed by ekeyd
  • pm-utils: needed by GNOME
  • printer-driver-*: renamed
  • python-dbus-dev: needed by the greeter, installer and more
  • python-pypdf: needed by bookletimposer
  • python-speechd: needed by orca
  • qdbus: needed by Tails Installer
  • speech-dispatcher: needed by orca
  • yelp-xsl: needed by Yelp

Remove

  • aptitude-common
  • db5.1-util
  • krb5-locales
  • openssh-blacklist
  • openssh-blacklist-extra
  • rpcbind

#6 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Resolved

Removed the packages marked for removal above (66bca6c).

Also available in: Atom PDF