Project

General

Profile

Feature #5878

Feature #5684: Screen locker

Add a lock screen action to the system menu

Added by Tails over 6 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/17/2016
Due date:
% Done:

100%

Feature Branch:
segfault:feature/5684-screen-locker
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Was implemented in feature/jessie, and then reverted in 4d2a7b565410d007c4713936a6904494fb991cab since we decided at the December 2014 meeting that the bigger problem was more complicated (#8383).


Subtasks

Feature #11256: Replace "Debian Live user" with a more descriptive full user nameResolved


Related issues

Blocked by Tails - Feature #8383: Research technical possibilities to implement a password prompt for screen locking Resolved 12/03/2014

History

#1 Updated by Tails over 6 years ago

  • Parent task set to #5684

#2 Updated by intrigeri over 6 years ago

  • Priority changed from Normal to Elevated

#3 Updated by BitingBird over 5 years ago

  • Subject changed from add a lock screen action to the shutdown button to Add a lock screen action to the shutdown button
  • Starter set to No

#4 Updated by intrigeri about 5 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 50

Was implemented in feature/jessie, and then reverted in 4d2a7b565410d007c4713936a6904494fb991cab since the bigger problem is more complicated (#8383).

#5 Updated by intrigeri about 5 years ago

  • Blocked by Feature #8383: Research technical possibilities to implement a password prompt for screen locking added

#6 Updated by BitingBird over 4 years ago

  • Blocked by deleted (Feature #8383: Research technical possibilities to implement a password prompt for screen locking)

#7 Updated by BitingBird over 4 years ago

  • Duplicates Feature #8383: Research technical possibilities to implement a password prompt for screen locking added

#8 Updated by BitingBird over 4 years ago

  • Duplicates deleted (Feature #8383: Research technical possibilities to implement a password prompt for screen locking)

#9 Updated by BitingBird over 4 years ago

  • Target version set to 2017

Same milestone as parent ticket

#10 Updated by intrigeri over 4 years ago

  • Blocked by Feature #8383: Research technical possibilities to implement a password prompt for screen locking added

#11 Updated by intrigeri about 4 years ago

  • Subject changed from Add a lock screen action to the shutdown button to Add a lock screen action to the system menu

(In GNOME Shell our interface to shutdown and reboot is in the "system menu", on the top-right of the screen; that's where the button to lock the screen lives in a normal GNOME Shell, so presumably it's also where our own locking button should live.)

#12 Updated by intrigeri about 4 years ago

  • Description updated (diff)

#13 Updated by intrigeri about 4 years ago

  • Description updated (diff)

#14 Updated by intrigeri over 3 years ago

  • Target version deleted (2017)

#15 Updated by segfault over 3 years ago

This was handled and reviewed on the parent ticket, #5684, see https://labs.riseup.net/code/issues/5684#note-50 and following.

#16 Updated by sajolida over 3 years ago

  • Assignee set to anonym
  • Target version set to Tails_2.6
  • QA Check set to Ready for QA

anonym: I'm sorry to bring up this issue once more but I don't see the screen locker in the system menu in 2.6~rc1 nor mentioned in the Changelog. So I understand that this won't be in 2.6. It's probably because the ticket was not marked for 2.6.

If my understanding is correct we should move this ticket to 2.8 as well as #11256, #6017, #10970 (or only the parent ticket but I still want #10970 to be marked explicity to see it better myself).

#17 Updated by sajolida over 3 years ago

Marking this for 2.6 until the status of the whole feature is clarified, see #5878#note-16.

#18 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.6 to Tails_2.9.1

#19 Updated by anonym about 3 years ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

Bumping this feature to the new next major release (given 2.8 was cancelled).

#20 Updated by anonym about 3 years ago

  • Feature Branch set to segfault:feature/5684-screen-locker

#21 Updated by anonym about 3 years ago

  • Assignee changed from anonym to segfault
  • QA Check deleted (Ready for QA)

Let's use the parent ticket for the review process.

#22 Updated by anonym about 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (segfault)

... or let's actually close sub-tickets when they are done.

Also available in: Atom PDF