Project

General

Profile

Feature #5870

Better support of non-commercial ISPs

Added by Tails about 6 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Non-commercial, ethical ISPs, such as the one who signed the data retention manifest, need to be better supported by Tails.

Our plans

  1. Install the SSL certificates/CA for such servers (on the long run, we want them to use "Monkeysphere":./monkeysphere.html but we're not there yet).
  2. Add bookmarks to the above-mentioned servers, in particular for quick'n'easy webmail access.

Implementation

SSL certificates

Iceweasel

The necessary NSS *.db files are:

  • cert8.db: can be generated from scratch by adding our custom SSL CA and server certificates with certutil
  • secmod.db: if this file is missing, a new one is generated without DSA, SHA256 and SHA512; weird.
  • key3.db: if missing, the other *.db files can't be used.

Related issues

Related to Tails - Bug #6704: CAcert.org root certificate is not included anymore Resolved 02/17/2014
Related to Tails - Feature #7436: Contact Riseup on how we could help towards publishing a list of recommended email providers Resolved 06/22/2014
Related to Tails - Feature #5766: Web browser profile with no CA Rejected
Related to Tails - Feature #7685: Document alternative email providers Rejected 10/27/2014
Related to Tails - Bug #15895: Remove our predefined bookmarks Resolved 09/02/2018

History

#1 Updated by BitingBird over 5 years ago

  • Subject changed from better support of non-commercial ISPs to Better support of non-commercial ISPs
  • Description updated (diff)
  • Starter set to No

#2 Updated by intrigeri about 5 years ago

  • Related to Feature #7436: Contact Riseup on how we could help towards publishing a list of recommended email providers added

#3 Updated by intrigeri over 3 years ago

#4 Updated by u about 1 year ago

  • Related to Feature #7685: Document alternative email providers added

#5 Updated by intrigeri 6 months ago

  • Related to Bug #15895: Remove our predefined bookmarks added

#6 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to Rejected
  1. Install the SSL certificates/CA for such servers

Thanks to Let's Encrypt, this is obsolete.

  1. Add bookmarks to the above-mentioned servers, in particular for quick'n'easy webmail access.

Looks like we've decided on #15895 to do the opposite.

Also available in: Atom PDF