Project

General

Profile

Feature #5867

windows theme

Added by Tails over 6 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

A set of boot splash screen / Desktop theme / iceweasel theme that mimic Microsoft Windows and Internet Explorer would be nice when using a public computer in order to raise less suspicion.

The Tails boot splash screen should be black with a tiny dots-based progress bar. Later on in the boot process, tails-greeter would provide a way to optionally start the GNOME session with a Windows look-alike theme; the Windows look would be the auto-selected default in case a Windows OS is detected on fixed disks. Users could make this setting persistent when using persistence. tails-greeter should look like Windows login screen (best would be to look like Windows XP, but looking like Windows NT4 login screen would be an acceptable, much easier, first implementation step).

Convenience/Tails features vs. stealth/windows look

How closely do we want to emulate the Windows look? Is it worth sacrificing certain features of the standard Gnome desktop of Tails in order to look more like Windows? Examples of potential (or even likely) differences (ignoring theming issues):

  • Application launchers
    • we probably should settle on only the most "translatable" application launchers with respect to how common some corresponding application is in Windows, e.g. Iceweasel is a keeper and it should have the Internet Explorer icon, but Seahorse should go as it has no counterpart in Windows.
  • Desktop icons
    • Windows certainly doesn't have "Report bug" and "Tails documentation" icons. OTOH these should normally be hidden behind some fullscreen window (e.g. Iceweasel).
  • Popups (e.g. from NetworkManager and Tails security check)
    • these will only be shown for a short time so they may be ok.
  • Systray icons
    • Like with launchers we should make these have icons from Windows when possible.

When it comes to themeing issues most of them may be solvable, but there's diminishing returns in how much you get for the time invested. In general the Windows camouflage feature can probably only be best effort. We'll never be able to perfectly emulate the Windows look completely. This is further complicated by that public computers may have custom theming/desktop wallpapers/launchers/desktop icons/tray icons. And if we want Iceweasel to look more like IE, which version of IE? And let's not even start talking about different version of Windows.

Hence, our goal shouldn't be that our theme should pass a close inspection, but rather that it shouldn't raise any alarms for someone glancing on the screen for a second or two in passing from a distance. We should focus on getting the things that are visible most of the time right, e.g. window styles, colour theme, cursor and panel.

Windows XP theme

XpGnome was the most suitable theme found. XpGnome is basically just a package gluing together three packages from Gnome-Look.org:

  • XPLuna for Windows XP looking themes for gtk and metacity.
  • GnomeXP for Windows XP icons.
    • In order to save space there's room for symlinking some of the many duplicate icons.
  • Cursor XP for a Windows cursor.

Except installing these, XpGnome's installation script also uses gconf to fix some further issues (desktop icons, panel etc.).

Implementation

  1. In the feature/winxp_theme branch we install homebrewn packages of the XpGnome components listed above, and have a script that does the gconf part. This feature can be activated by putting "winxp" on the kernel command-line.

What remains to do

  1. See "custom plymouth theme":./custom_plymouth_theme.html.
  2. "enable Windows camouflage when installed Windows detected":./enable_Windows_camouflage_when_installed_Windows_detected.html
  3. "fix Windows camouflage display bugs":./.html
  4. See "newer Windows theme":./newer_Windows_theme.html.

Other miscellaneous ideas

It was also proposed on the forum to:

  • "reuse installed Windows wallpaper":./reuse_installed_Windows_wallpaper.html
  • Use a splash screen at boot that looks like a paused video player.

Related issues

Related to Tails - Feature #5948: Custom plymouth theme Confirmed

History

#1 Updated by intrigeri over 6 years ago

  • Type of work set to Code

Type of work: Code

Also available in: Atom PDF