Project

General

Profile

Bug #5823

Pidgin answers CTCP ping and version

Added by Tails about 6 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
09/19/2013
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Pidgin responds to PING and VERSION (with "Purple IRC"). Beware when testing that: Pidgin itself seems to be buggy when it comes to sending CTCP requests, so better use another client.


Subtasks

Bug #6283: Decide if we care about the Pidgin CTCP repliesResolved


Related issues

Related to Tails - Bug #6347: Pidgin IRC Protocol responds to DCC SEND? Confirmed 10/08/2013

History

#1 Updated by intrigeri almost 6 years ago

  • Type of work changed from Research to Code
  • Starter set to No

#2 Updated by intrigeri almost 6 years ago

  • Tracker changed from Feature to Bug
  • Subject changed from Pidgin ctcp replies to Pidgin answers CTCP ping and version

#3 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to Rejected

At the monthly meeting, we decided we don't care much about PING (mostly harmless, and can be deduced in other ways) and VERSION (there are probably other weirdness in
how the protocol is implemented, that disclose as much).

If anyone feels like it, the next step is to have an option implemented upstream, that allows one to hide this information (verifying that not replying to VERSION actually leaks less than replying Purple IRC first is left as an exercise to the reader).

#4 Updated by BitingBird over 4 years ago

Testing today, I got no response to PING, only to VERSION.

#5 Updated by intrigeri over 4 years ago

Testing today, I got no response to PING, only to VERSION.

That's because our manual test suite doc is buggy: it advises to use https://webchat.oftc.net/ to send CTCP PING, that it apparently doesn't support correctly, so it's no surprise that it gets no answer; going to fix that right now. Using Konversation to send a CTCP PING command shows that Tails 1.2.3's Pidgin does reply to it.

#6 Updated by u about 1 year ago

  • Related to Bug #6347: Pidgin IRC Protocol responds to DCC SEND? added

Also available in: Atom PDF