Project

General

Profile

Feature #5735

Do not start the browser automatically

Added by Tails over 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
08/10/2013
Due date:
% Done:

100%

Feature Branch:
feature/dont_autostart_iceweasel
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Browser

Description

Specification

It was reported that iceweasel autostarting is suboptimal: its startup timing is a bit weird wrt. the session startup: depending on many parameters, it pops up at a unexpected time, in a way that surprises many users ("oh, what's happening?!") and makes the Tails UX seemingly random.

The main reason why we autostart iceweasel was to make it clear to the user when Tor is ready enough to browse the web.

So, I propose we replace iceweasel autostart with a "Tor is now ready!" desktop notification.

However, once we don't autostart iceweasel, many users will probably click its launcher in the GNOME panel at various times in the time sync' process, so we should have this launcher start a wrapper that accordingly warns if Tor is not ready yet, before allowing starting the browser anyway (because currently, this is the browser that should be used to reach the LAN, so users should be able to use it offline).

Implementation

To end with, if we implement this, the profiling script should probably be adapted to wait for another process.

The profiling script was actually just waiting some time


Subtasks

Feature #6230: Adapt the test suite: we do not automatically start the browser anymoreResolvedintrigeri

Feature #6231: don't autostart iceweasel: test l10nResolved

Feature #6573: Localize Iceweasel wrapper scriptResolved


Related issues

Blocks Tails - Feature #6014: incremental upgrades: complete phase three Resolved 11/28/2013

History

#1 Updated by intrigeri almost 6 years ago

  • Assignee set to intrigeri
  • Target version set to Tails_0.22.1
  • Starter set to No

Blocks incremental upgrades, so now a candidate for 0.22.1.

#2 Updated by intrigeri almost 6 years ago

  • Subject changed from dont autostart iceweasel to Do not start the browser automatically

#3 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri almost 6 years ago

  • Assignee changed from intrigeri to sajolida
  • QA Check set to Ready for QA

#5 Updated by intrigeri almost 6 years ago

  • Assignee changed from sajolida to intrigeri
  • Feature Branch set to feature/dont_autostart_iceweasel

#6 Updated by intrigeri almost 6 years ago

  • Category set to 176
  • Status changed from In Progress to 11
  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Merged into stable and devel.

#7 Updated by intrigeri almost 6 years ago

  • Status changed from 11 to In Progress
  • Assignee set to sajolida
  • QA Check changed from Pass to Ready for QA

The test/dont_autostart_iceweasel branch is still pending review'n'merge.

#8 Updated by intrigeri almost 6 years ago

  • Assignee changed from sajolida to bertagaz

Reassigning to bertagaz for the review of test/dont_autostart_iceweasel.

#9 Updated by bertagaz almost 6 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (bertagaz)
  • QA Check changed from Ready for QA to Pass

#10 Updated by intrigeri almost 6 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF