Project

General

Profile

Feature #5711

Persistence preset: Liferea

Added by Tails about 6 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Persistence
Target version:
-
Start date:
11/04/2013
Due date:
% Done:

100%

Feature Branch:
feature/5711-liferea-persistence-preset
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Feed Reader

Description

It would be nice to provide a persistence preset for Liferea (that makes little sense to be used without persistence, actually).

However, that piece of software uses versioned configuration directories (e.g. ~/.liferea_1.8/) so if we do it right now, we will have to handle the Squeeze -> Wheezy transition.

A cheaper plan could be:

  1. wait for Tails on Wheezy to be close enough
  2. Implement this feature in time to ship it with the first Tails based on Wheezy.
  3. Kindly ask upstream if they would not mind using a single, unversioned config directory name.

Subtasks

Feature #6402: Backport liferea 1.10.3 to wheezy-backportsResolvedalant

Feature #6403: Implement Liferea persistence presetRejected

Feature #7154: Install liferea > 1.10.3Rejected

Bug #7350: Use HTTP proxy instead of torsocks for Liferea 1.10.3+Rejected

Bug #7351: Liferea: clicking on the title of a feed doesn't update itRejected


Related issues

Related to Tails - Feature #7625: Persistence preset: RSS feeds Duplicate 07/20/2014
Related to Tails - Bug #9429: Liferea internal browser's Javascript should be disabled by default Rejected 05/19/2015

History

#1 Updated by intrigeri about 6 years ago

  • Type of work changed from Wait to Code

#2 Updated by alant almost 6 years ago

  • Starter set to No

Upstream version 1.10.3 use an XDG-compliant unversioned config directory name (.config/liferea)

This version is in jessie and can be backported to wheezy whithout any changes.

#3 Updated by intrigeri almost 6 years ago

wrote (04 Nov 2013 16:48:28 GMT) :

Upstream version 1.10.3 use an XDG-compliant unversioned config directory name (.config/liferea)

Great!

This version is in jessie and can be backported to wheezy whithout any changes.

Cool. Would you (kindly) ask the liferea maintainers in Debian if
they're interested to prepare and maintain such a backport?

#4 Updated by alant almost 6 years ago

  • Assignee set to alant

#5 Updated by alant almost 6 years ago

Cool. Would you (kindly) ask the liferea maintainers in Debian if
they're interested to prepare and maintain such a backport?

Done, see the subtask #6402

#6 Updated by intrigeri over 5 years ago

  • Subject changed from persistence preset - liferea to Persistence preset: Liferea

#7 Updated by alant over 5 years ago

  • Feature Branch set to feature/5711-liferea-persistence-preset

There is in implementation ready to test in feature/5711-liferea-persistence-preset

#8 Updated by alant over 5 years ago

  • Target version set to Tails_1.1

#9 Updated by alant over 5 years ago

  • Status changed from Confirmed to In Progress

#10 Updated by intrigeri over 5 years ago

alant wrote:

There is in implementation ready to test in feature/5711-liferea-persistence-preset

I wanted to have a look, but I can see this branch neither in the main Git repo, nor in the t-p-s one.

Apart of actually publishing the code, what's left to be done?

#11 Updated by alant over 5 years ago

Apart of actually publishing the code, what's left to be done?

There were connection issues with liferea 1.10. I'm investigating a fix.

#12 Updated by alant over 5 years ago

  • Assignee changed from alant to anonym
  • QA Check set to Ready for QA

#13 Updated by intrigeri over 5 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

More dev needed, see tails-dev@. I'll take care of it.

#14 Updated by intrigeri over 5 years ago

As I wrote on tails-dev@:

   [...] the one (presumably anonym) who will package this new code
   will need to add {build,runtime}-dependencies on the package that
   ships the liferea icon. See commit b76b911 for a past example of
   such a debian/control update.

#15 Updated by intrigeri over 5 years ago

  • Assignee changed from intrigeri to alant

I've fixed the problems I had identified initially, and discovered more blockers. See tails-dev@.

#16 Updated by intrigeri over 5 years ago

  • Category set to Persistence

#17 Updated by alant over 5 years ago

These issues were discuvered during review:

  • Feeds that I had already fetched, and read some articles from, are empty after a reboot. When updating it again, the articles I had read already now appeared as unread. I consider this to be a clear blocker.
  • Clicking on a feed title in the sidebar is not enough to update it. One has to right-click -> Update. Arguably, that's a minor UI issue. Is it a regression since Tails 1.0?
  • Liferea has an internal browser, with JavaScript enabled. Not checked if that's the same in Tails 1.0. This browser has a URL bar, and can be used to browser random web pages. I consider this as a serious bug: Tails should not allow people to so easily browse the web with a much less protected browser, without being aware of the possible problems it may cause. If that's a regression since 1.0, then that's a clear blocker for merging this branch. Else, it's "only" a Priority>>normal bug we've been carrying.
  • If I don't have a Tor Browser running yet, "Right-click -> Open in external browser" doesn't work for me: a new tab is open in Tor Browser, with the right URL, but the page content is not loaded. That external browser seems pretty much disfunctional anyway, I can't load any URL in it. I bet it's simply because the "run with torsocks" thing is inherited by the Tor Browser started by Liferea. This leads me to think that using usewithtor/torsocks was a bad idea, and that configuring a HTTP proxy in Liferea would be much better. I think that's a blocker too.

#18 Updated by alant over 5 years ago

  • Status changed from In Progress to Confirmed
  • Assignee deleted (alant)
  • Target version deleted (Tails_1.1)
  • QA Check deleted (Dev Needed)

Removing target version and unassigning the feature as the plan failed.

#19 Updated by alant about 5 years ago

We decided not to use liferea anymore for feed persistence but to wait for thunderbird integration.

#20 Updated by alant about 5 years ago

#21 Updated by intrigeri about 5 years ago

#22 Updated by intrigeri about 5 years ago

  • Status changed from Confirmed to Rejected

#23 Updated by sajolida over 4 years ago

  • Related to Bug #9429: Liferea internal browser's Javascript should be disabled by default added

#24 Updated by sajolida over 3 years ago

  • Affected tool set to Feed Reader

Also available in: Atom PDF