Project

General

Profile

Feature #5707

Test suite: split various checks feature

Added by Tails over 6 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
test/5707-split-checks.feature
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

As currently implemented, checks.feature mixes various unrelated checks for the sole reason of improving the test suite runtime. Unfortunately, this is deemed to result in a quickly growing bitrot space.

Instead, the scenarii that are currently in there should be split into functionally grouped independent features, that would share a tag expressing that they can share a common background snapshot.


Related issues

Blocked by Tails - Feature #6094: Test suite: background snapshot improvements Resolved 10/15/2015

Associated revisions

Revision cb287455 (diff)
Added by anonym over 3 years ago

Split scenarios from checks.feature into sane_defaults.feature.

Will-fix: #5707

Revision 6802eb55 (diff)
Added by anonym over 3 years ago

Split scenarios from checks.feature into gnome.feature.

Will-fix: #5707

Revision d066bcae (diff)
Added by anonym over 3 years ago

Split scenarios from checks.feature into emergency_shutdown.feature.

Will-fix: #5707

Revision ec0e28f7 (diff)
Added by anonym over 3 years ago

Split scenarios from checks.feature into virtualization.feature.

Will-fix: #5707

Revision 7b9bd02e (diff)
Added by anonym over 3 years ago

Split scenarios from checks.feature into hardening.feature.

Will-fix: #5707

Revision e3992d2a (diff)
Added by anonym over 3 years ago

Split scenarios from checks.feature into keys.feature.

Will-fix: #5707

Revision 44c659c1 (diff)
Added by anonym over 3 years ago

Split scenarios from checks.feature into documentation.feature.

Will-fix: #5707

Revision b7124bba (diff)
Added by anonym over 3 years ago

Split scenarios from checks.feature into networking.feature.

Will-fix: #5707

Revision 75a8cef5 (diff)
Added by anonym over 3 years ago

Move another scenario out of checks.feature.

I lack the imagination for a more suitable feature than this.

Will-fix: #5707

Revision c636a017 (diff)
Added by anonym over 3 years ago

Split last scenario from checks.feature into regression_tests.feature.

Will-fix: #5707

History

#1 Updated by intrigeri about 6 years ago

  • Category set to Test suite
  • Starter set to No

#2 Updated by BitingBird over 5 years ago

  • Subject changed from test suite: split various checks feature to Test suite: split various checks feature

#3 Updated by anonym almost 5 years ago

  • Blocked by Feature #6094: Test suite: background snapshot improvements added

#4 Updated by anonym almost 5 years ago

  • Target version set to Tails_2.4

#7 Updated by anonym about 4 years ago

  • Assignee set to anonym

#9 Updated by intrigeri over 3 years ago

  • Priority changed from Normal to Elevated

#11 Updated by intrigeri over 3 years ago

  • Priority changed from Elevated to High

#12 Updated by anonym over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from anonym to bertagaz
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/5707-split-checks.feature

There's some serious lack of imagination in the topic branch, I guess. Suggestions of improvements are welcome! Also I skipped the As a Tails user/developer... intro text since I find it a worthless exercise in semi-creative writing. If someone can point out to me what problem it is supposed to solve I'll give it a try.

#13 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#14 Updated by bertagaz over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Code review didn't give me much more inspiration, so it seems fine to me as it is. Running the new features does not raise any issue either, so merged it, congrats!

#15 Updated by intrigeri over 3 years ago

  • Status changed from Resolved to Fix committed
  • Target version changed from Tails_2.5 to Tails_2.6

(Seems like this was merged into devel only, so it can't be in 2.5. And it's "Fix committed" until we've released.)

#16 Updated by anonym about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF