Project

General

Profile

Feature #5701

Port Tails Greeter to Python 3

Added by Tails about 6 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
feature/8230-greeter-revamp-phase1
Type of work:
Code
Starter:
No
Affected tool:
Greeter

Description

Dependencies in Debian:

  • python-dbus: python3-dbus
  • python-gobject: python3-gi
  • python-lxml: python3-lxml
  • python-pycountry: python3-pycountry
  • python-pyicu: python3-icu
  • python-xklavier: gir1.2-xkl-1.0

Related issues

Related to Tails - Feature #5875: Make sure all the Python 3 libraries we need are in Jessie Resolved 07/19/2013 08/31/2014

History

#1 Updated by intrigeri about 6 years ago

  • Category set to 165

#2 Updated by intrigeri almost 6 years ago

  • Parent task set to #5958
  • Starter set to No

#3 Updated by BitingBird about 5 years ago

  • Subject changed from migrate tails-greeter to Python 3 to Migrate tails-greeter to Python 3

#4 Updated by intrigeri about 5 years ago

  • Related to Feature #5875: Make sure all the Python 3 libraries we need are in Jessie added

#5 Updated by intrigeri about 5 years ago

  • Subject changed from Migrate tails-greeter to Python 3 to Migrate the Greeter to Python 3

See #5875, and more specifically the blueprint and #6175, for existing and more up-to-date research in this area.

#6 Updated by BitingBird over 4 years ago

  • Blueprint set to https://tails.boum.org/blueprint/python3/

#7 Updated by BitingBird over 4 years ago

I found a python-pycountry in python3 (https://packages.qa.debian.org/p/pycountry.html, look at the binaries).

#8 Updated by intrigeri over 4 years ago

I found a python-pycountry in python3

Indeed, we've fixed that already (as was discussed on #5875 and #7788). The best place to add/update such info is the blueprint.

#9 Updated by BitingBird over 4 years ago

  • Description updated (diff)

#10 Updated by intrigeri almost 4 years ago

  • Subject changed from Migrate the Greeter to Python 3 to Port Tails Greeter to Python 3

#11 Updated by intrigeri almost 4 years ago

  • Assignee set to alant
  • QA Check set to Info Needed

This ticket's description and the blueprint contradict each other wrt. icu. May you please merge/deduplicate them?

Once this is done, depending on the outcome, perhaps this ticket will become a code task :)

#12 Updated by alant almost 4 years ago

  • Assignee deleted (alant)
  • QA Check deleted (Info Needed)
  • Type of work changed from Research to Code

intrigeri wrote:

This ticket's description and the blueprint contradict each other wrt. icu. May you please merge/deduplicate them?

python3-icu is now in debian:

python3-icu |      1.8-1 | http://ftp.fr.debian.org/debian/ jessie/main amd64 Packages

Once this is done, depending on the outcome, perhaps this ticket will become a code task :)

Done

#13 Updated by intrigeri almost 4 years ago

  • Assignee set to alant

Perhaps I was not clear enough. The ticket description and blueprint still disagree, at least on the ICU topic. I was going to entirely kill the description from the ticket because it seems to be less up-to-date, but it contains more info than what's on the blueprint, so I'd appreciate if you deduplicated/merged them (preferably by moving relevant info from the ticket to the blueprint).

#14 Updated by alant about 3 years ago

  • Description updated (diff)

This will by done in the greeter revamp (#8230)

#15 Updated by alant about 3 years ago

  • Status changed from Confirmed to In Progress

#16 Updated by alant about 3 years ago

#17 Updated by alant over 2 years ago

#18 Updated by alant over 2 years ago

  • % Done changed from 0 to 100
  • Parent task deleted (#5958)
  • Feature Branch set to feature/8230-greeter-revamp-phase1

This is fixed in feature/8230-greeter-revamp-phase1.

#19 Updated by alant over 2 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (alant)

#20 Updated by intrigeri about 2 years ago

  • Status changed from Fix committed to Resolved
  • Target version set to Tails_3.0

Also available in: Atom PDF