Project

General

Profile

Feature #5685

Document how to install new software

Added by Tails about 6 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
No
Affected tool:

Description

  • Tails includes a coherent but limited set of applications. More applications can be installed as on any Debian installation.
  • Since Tails is amnesic they need to be reinstalled for each working session unless you use the "Additional software" persistence feature. See remember installed packages (#5551).
  • Document better the APT and additional software features of the persistence.
  • Look for external documentation about Synaptic.
  • Discuss if we should include other ways of installing packages (software-center?).

Related issues

Duplicated by Tails - Bug #8392: Document how to install additional packages Duplicate 12/05/2014

Associated revisions

Revision 95210413
Added by sajolida over 4 years ago

Merge branch 'doc/5685-new_software' (Closes: #5685)

Conflicts:
wiki/src/doc/first_steps/startup_options/administration_password.mdwn

History

#1 Updated by sajolida almost 6 years ago

  • Subject changed from document how to install new software to Document how to install new software
  • Starter set to No

#2 Updated by intrigeri about 5 years ago

  • Blocks deleted (Feature #6860: Conduct a usability testing session on Tails at NUMA)

#3 Updated by BitingBird over 4 years ago

  • Duplicated by Bug #8392: Document how to install additional packages added

#4 Updated by BitingBird over 4 years ago

Info from duplicate ticket:

People not familiar with Linux/Debian don't know how to do that.

It should be linked from https://tails.boum.org/doc/first_steps/startup_options/administration_password/index.en.html and https://tails.boum.org/doc/about/features/index.en.html

boot with admin password
apt-get update
apt-get install [software] (must be packaged in Debian)

Or synaptic/other tool.

Persistence if you want it each time.

Things that need network will need to be configured to go through Tor.

Warnings, etc.

#5 Updated by BitingBird over 4 years ago

  • Assignee set to sajolida
  • Target version set to Tails_1.3
  • QA Check set to Ready for QA
  • Feature Branch set to bitingbird:doc/5685-new_software

First version, I didn't explain synaptic. Made the relevant links from other places, added to index (i put it in the "advanced topics" because I was not sure where else).

#6 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Info Needed

BitingBird, I think you forgot to push that branch.

#7 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Info Needed to Ready for QA

Pushed.

#8 Updated by intrigeri over 4 years ago

  • Feature Branch changed from bitingbird:doc/5685-new_software to doc/5685-new_software

Rebased on master to remove unrelated commits.

#9 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Dev Needed

Thanks. I pushed a few changes on origin, and here are a few more comments:

  • In English, "software" in uncountable, so you can't say "a software".
  • Do a git grep on the wiki to find the usual and more technically correct version of "you need to select the administration password startup option". Reuse is the key!
  • Typing sudo apt-get update & sudo apt-get install $software for each package seems suboptimal, could you split that into two and ask for sudo apt-get update only once. Plus that will make the process more transparent: first update the list of packages, then install what you need. We're in the "advanced topics" so that fits here.
  • Use numbered list when documenting steps.
  • Regarding "will need to be", it's better to avoid both future tense (almost always) and passive mode (as much as possible). Plus, shall we be more explicit and maybe say "cannot access the network unless configured to go through Tor"?
  • Add empty lines between HTML structures, see 5d0e104.

#10 Updated by BitingBird over 4 years ago

You renamed "new software" to "additional software", which makes sense... except I had intentionnaly used "new" in order to avoid confusion with the persistence-"additional software" feature. Not sure what's better now, but I think having 2 things named similarly might be bad.

#11 Updated by sajolida over 4 years ago

You renamed "new software" to "additional software", which makes
sense... except I had intentionnaly used "new" in order to avoid
confusion with the persistence-"additional software" feature. Not
sure what's better now, but I think having 2 things named similarly
might be bad.

I think that they are actually the same thing: packages that you add to
you normal Tails install. In technical terms it's the same `apt-get
install` command in both cases with the same effects. The only
difference is that one mechanism is a persistence feature (and makes
them persistent), the other one is not.

Similarly the persistence feature called "Browser bookmarks" or
"Printers" are called the same way as usual "browser bookmarks" and
"printers" :)

#12 Updated by intrigeri over 4 years ago

Very convincing. IIRC I was the one who initially asked BitingBird to avoid reusing the same terminology to avoid confusion, but now I'm convinced. Sorry, BitingBird!

#13 Updated by BitingBird over 4 years ago

  • Priority changed from Normal to Elevated

#14 Updated by BitingBird over 4 years ago

Resetted, I'll work on this further now :)

#15 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Ready for QA

Applied all your remarks in small commits, added a small note about dependencies and installing multiple packages. Please review :)

#16 Updated by sajolida over 4 years ago

  • Assignee changed from sajolida to BitingBird
  • QA Check changed from Ready for QA to Dev Needed

The last commit on your branch is still from me. So maybe you forgot to push it. See https://git-tails.immerda.ch/bitingbird/tails/log/?h=doc/5685-new_software.

#17 Updated by BitingBird over 4 years ago

  • Assignee changed from BitingBird to sajolida
  • QA Check changed from Dev Needed to Ready for QA

Pushed, sorry for the delay :)

#18 Updated by sajolida over 4 years ago

  • Target version changed from Tails_1.3 to Tails_1.3.2

At first sight, this needs more work and I won't be able to do it in time for 1.3, so I'm postponing to 1.3.1.

#19 Updated by sajolida over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#20 Updated by sajolida over 4 years ago

  • Assignee deleted (sajolida)
  • Target version deleted (Tails_1.3.2)
  • QA Check deleted (Ready for QA)

#21 Updated by sajolida over 4 years ago

Actually, people even not very knowledgable about the command line are able to run the right apt-get command if guided well. And this is definitely easier to do that documenting Synaptic.

#22 Updated by BitingBird over 4 years ago

I just reviewed your changes and found a tiny mistake: "replacing [software] with the name of the package" should be "replacing [package] with the name of the package".

Thanks for reviewing and merging this !

#23 Updated by BitingBird over 4 years ago

  • Status changed from Resolved to In Progress
  • Feature Branch deleted (doc/5685-new_software)

Re-opening for the tiny mistake, and also because I should put a link from https://tails.boum.org/doc/first_steps/persistence/configure#index8h2 to the new page :)

#24 Updated by BitingBird over 4 years ago

the link from persistence is worked on in #8419, so only the tiny software-> package is left.

#25 Updated by BitingBird over 4 years ago

  • Assignee set to sajolida

#26 Updated by sajolida over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Fixed in bd2b194.

Also available in: Atom PDF