Project

General

Profile

Feature #5663

Return to Icedove

Added by Tails about 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
10/16/2013
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Starter:
No
Affected tool:
Email Client

Subtasks

Feature #6148: Torbirdy in DebianResolved

Feature #6153: maybe throw keyidsResolved

Feature #6152: decide on throw keyidsResolved

Feature #6154: Secure the Icedove autoconfig wizardResolved

Feature #6157: Fix re-test in secure Icedove autoconfig wizardResolved

Feature #6158: Fix secure Icedove autoconfig wizard in TailsResolved

Feature #6367: Rebase our patches on top of Icedove 24Resolved

Feature #6368: Test our rebased patches on Icedove 38Resolved

Feature #6369: Build Debian packages of Icedove 38 with our patches / create proper branch situationResolved

Feature #7064: Update our plans for securing Icedove's autoconfig wizard wrt. recent developmentsResolved

Feature #6149: Wait for Torbirdy patches design documentationResolved

Feature #7746: Rebase our patches on top of Icedove 38Resolved

Feature #9492: Adapt the patchset to work on current IcedoveDuplicate

Feature #11204: Make sure we get all the benefits from TorBirdy's own account wizardResolved

Feature #11215: Update Icedove design documentation wrt. the autoconfig wizardResolved

Feature #11503: Update our doc to the Icedove autoconfig wizardResolved

Feature #6155: test if Torbirdy spoofs User-AgentResolved

Bug #7103: Verify that GnuPG does not leak timezone in email signaturesResolved

Feature #7158: Update Icedove documentationResolved

Feature #7587: Have icedove co-installable with xul-ext-foxyproxy-standardResolved

Feature #7773: Design and implement migration plan for Claws Mail persistent settings and dataResolved

Feature #9494: Identify the most common Claws Mail persistence configurationsResolved

Feature #9495: Documentation migration from Claws Mail to IcedoveResolved

Feature #9496: Draft "sorry" documentation for remaining Claws Mail to Icedove migration known issuesRejected

Feature #9497: Polish the Claws Mail to Icedove migration documentationRejected

Feature #9498: Enable Icedove persistence when Claws Mails persistence was enabledResolved

Feature #10453: Provide a script to migrate from the default MH mailbox to IcedoveResolved

Feature #10454: Improve the user-facing strings of the migration scriptResolved

Feature #10457: Consider shipping the nmh package for some timeResolved

Feature #10458: Consider adding a warning when starting Icedove with Claws Mail persistence featureResolved

Feature #10459: Consider adding a warning when starting Claws Mail once it's deprecatedRejected

Bug #8276: TorBirdy disables the Icedove autoconfiguration by defaultResolved

Feature #9493: Write Icedove manual tests for common usecases and security requirementsResolved

Bug #9821: Torbirdy uses Arabic as a default localeResolved

Feature #10005: Create a public mailing list for the move to IcedoveResolved

Feature #10006: Subscribe Icedove mailing list to Redmine feed on email clientResolved

Feature #6150: Help Tor people upstream the Torbirdy patchesResolved

Feature #10007: Hide irrelevant TorBirdy optionsResolved

Feature #9303: Consider proposing POP instead of IMAP by defaultResolved

Feature #10010: Decide how long to keep Claws Mails once we have IcedoveResolved

Feature #10009: Decide whether to disable remote email account creation in IcedoveResolved

Feature #10167: Remove Claws MailResolved

Feature #9499: Replace the Claws Mail persistence feature with Icedove oneResolved

Feature #10447: Adjust our documentation to the removal of Claws MailResolved

Bug #10904: tor-tsocks-mua.conf left over from Claws Mail removalResolved

Feature #10285: Add Icedove (and its related packages) to TailsResolved

Feature #10436: Consider disabling the Enigmail wizard on first startRejected

Bug #10428: Disable add-on updates in IcedoveResolved

Feature #10446: Update our doc to Icedove being the recommended email clientResolved

Feature #10464: Disable remote email account creation in IcedoveResolved

Feature #10574: Change default protocol (IMAP vs POP3) depending on whether persistence is enabled or notResolved

Feature #10737: Update our design documentation to the return of IcedoveResolved

Feature #10739: Replace the Claws Mail launcher by IcedoveResolved

Bug #10742: Remove the Claws Mail persistence feature from the Persistence AssistantResolved

Feature #10743: tails-persistence-setup depends on claws-mailDuplicate

Bug #10752: Investigate the current security status of Icedove + NSS as shipped in Tails 1.7 & 1.8Resolved

Bug #10753: Investigate release timing of IcedoveResolved

Feature #10756: Icedove wrapper is not integrated in our i18n systemResolved

Bug #10905: Override Torbirdy default settings in a more maintainable wayResolved

Bug #10906: Enigmail is configured to use a cleartext hkp:// keyserverResolved

Bug #10933: Icedove can't send mails through Riseup's and Boum's SMTPResolved

Feature #11484: Upstream config/chroot_local-patches/torbirdy-0001-secure-autoconfig-compat.diffRejected

Bug #11486: Icedove autoconfig wizard gets stalled on some domainsResolved

Bug #11530: Upgrade icedove to 45.1.0esrResolved

Bug #11613: Missing APT pinning for IcedoveResolved

Bug #11614: Missing icedove-l10n-* in our custom APT repositoryResolved

Bug #11619: Torbirdy patches need updatingResolved


Related issues

Related to Tails - Feature #7626: Investigate using Thunderbird & TorBirdy as the RSS reader Resolved 05/05/2016
Related to Tails - Bug #9422: Consider disabling key management feature of Enigmail Resolved 05/18/2015

History

#1 Updated by Tails about 6 years ago

  • Blueprint set to https://tails.boum.org/blueprint/Return_of_Icedove__63__

#2 Updated by Tails about 6 years ago

  • Priority changed from Normal to High

#3 Updated by intrigeri about 6 years ago

  • Type of work changed from Wait to Code

#4 Updated by intrigeri about 6 years ago

  • Subject changed from Return of Icedove? to Return to Icedove

#5 Updated by BitingBird over 5 years ago

  • Category set to 176
  • Starter set to No

#6 Updated by intrigeri over 5 years ago

  • Category deleted (176)

Icedove is a mail client, not a browser.

#7 Updated by BitingBird over 5 years ago

  • Category set to 176

#8 Updated by BitingBird over 5 years ago

  • Category deleted (176)

#9 Updated by sajolida about 5 years ago

  • Target version set to Sustainability_M1

non-blocker

#10 Updated by intrigeri about 5 years ago

  • Related to Feature #7626: Investigate using Thunderbird & TorBirdy as the RSS reader added

#11 Updated by intrigeri about 5 years ago

  • Category set to 212

#12 Updated by matsa over 4 years ago

For the record, it's possible to install Icedove in Tails 1.2.3 with the following command line:

apt-get install icedove enigmail xul-ext-torbirdy/testing
(and eventually icedove-l10n-YourLocale)

#13 Updated by matsa over 4 years ago

Update: maybe the following command line is more correct:

apt-get install icedove enigmail xul-ext-torbirdy/jessie
Successfully tested:
  • setup and retrieve an IMAP account (at riseup, I just had to change the SMTP server to mail.riseup.net)
  • create a PGP key and revocation certificate with enigmail
  • send and receive an encrypted and signed email

#14 Updated by sajolida over 4 years ago

  • Related to Bug #9422: Consider disabling key management feature of Enigmail added

#16 Updated by intrigeri over 4 years ago

  • Assignee set to u
  • Target version changed from Sustainability_M1 to 246

#17 Updated by intrigeri over 4 years ago

  • Blocks deleted (Feature #6304: Automate the most important bits of the Icedove tests)

#18 Updated by sajolida almost 4 years ago

  • Target version changed from 246 to Tails_2.0

#19 Updated by u over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#21 Updated by u over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#22 Updated by anonym over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#23 Updated by u over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#24 Updated by BitingBird about 3 years ago

  • Status changed from Confirmed to In Progress

#25 Updated by intrigeri about 3 years ago

  • Target version changed from Tails_2.5 to Tails_2.7

#26 Updated by u almost 3 years ago

  • Status changed from In Progress to Duplicate
  • Assignee deleted (u)

We unparented the remaining tickets which still need some work, because this parent ticket now does not help us further to organize this remaining work. And we've released Icedove in Tails months ago.

#27 Updated by u almost 3 years ago

  • Status changed from Duplicate to Resolved

Also available in: Atom PDF