Project

General

Profile

Feature #5567

Allow opting-out of additional software installation in the Greeter

Added by Tails about 6 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Persistence
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:
Greeter

Description

Allow to opt-out of the installation of additional software packages in the greeter


Related issues

Related to Tails - Feature #5551: Remember installed packages Rejected 07/20/2014
Related to Tails - Feature #14568: Additional Software Packages Resolved 12/11/2013 06/26/2018

History

#1 Updated by Tails about 6 years ago

  • Parent task set to #5551

#2 Updated by intrigeri almost 6 years ago

  • Category set to Persistence
  • Starter set to No

#3 Updated by intrigeri over 5 years ago

  • Subject changed from additional software: opt-out installation in the greeter to Allow opting-out of additional software installation in the greeter

#4 Updated by intrigeri about 5 years ago

  • Assignee set to alant
  • QA Check set to Info Needed

I've not seen this feature requested via our user support channels. Do we still think it's important enough to provide it, and make the Greeter UI more complex? If not, I propose we close this ticket as rejected. Alan, what do you think?

#5 Updated by alant about 5 years ago

Do we still think it's important enough to provide it, and make the Greeter UI more complex?

I still find it relevant but not important so I won't oppose rejecting this feature.

#6 Updated by intrigeri about 5 years ago

  • Assignee deleted (alant)
  • Priority changed from Normal to Low
  • QA Check deleted (Info Needed)

OK, keeping it around, but lowering priority, then.

#7 Updated by BitingBird over 4 years ago

  • Affected tool set to Greeter

#8 Updated by BitingBird over 4 years ago

  • Subject changed from Allow opting-out of additional software installation in the greeter to Allow opting-out of additional software installation in the Greeter

#9 Updated by intrigeri almost 2 years ago

I don't think this task is part of SponsorW_2017. Ulrike, can we move it out of that view then?

#10 Updated by sajolida almost 2 years ago

Ack!

#11 Updated by u almost 2 years ago

  • Parent task deleted (#5551)

#12 Updated by u almost 2 years ago

#13 Updated by u almost 2 years ago

#14 Updated by u about 1 year ago

  • Status changed from Confirmed to Rejected

This can now be configured by the user thanks to #14568. I'm thus rejecting this ticket as proposed by intrigeri and alant before.

#15 Updated by intrigeri about 1 year ago

This can now be configured by the user thanks to #14568.

AFAIK this is incorrect: if one unlocks their persistent volume in the Greeter and they've packages listed in their ASP config file, there's no way to opt-out from installation.

I'm thus rejecting this ticket as proposed by intrigeri and alant before.

Yes!

#16 Updated by u about 1 year ago

intrigeri wrote:

This can now be configured by the user thanks to #14568.

AFAIK this is incorrect: if one unlocks their persistent volume in the Greeter and they've packages listed in their ASP config file, there's no way to opt-out from installation.

But they may reconfigure this and delete those packages afaik.

#17 Updated by intrigeri about 1 year ago

But they may reconfigure this and delete those packages afaik.

Sure! I think we've understood this ticket differently:

  • It seems you've understood this as a way to permanently disable installation of some packages among the ASP list.
  • I understand it as a way to temporarily disable installation of all ASP, which can be useful e.g. because I'm in a hurry and don't want to wait for my big list of ASP to install, or because help desk asked me to disable my ASP to debug a problem I've reported and that might be caused by it (but I still need the rest of my persistent settings to reproduce the problem).

Anyways :)

Also available in: Atom PDF