Project

General

Profile

Feature #5530

Don't display the splash screen for some applications in Windows Camouflage mode

Added by Tails over 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Camouflage
Target version:
Start date:
Due date:
% Done:

50%

Feature Branch:
feature/5530-disable-splash-screens-in-camouflage-mode
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Improvement for Windows Camouflage:

  • add --no-splash startup setting to those applications: scribus, gimp

win8_no_splash.txt View (1.14 KB) hybridwipe, 08/06/2015 10:35 PM

win8_nosplash2.txt View (1.44 KB) hybridwipe, 08/07/2015 02:05 PM

tails-prepare-win8-theme-use-exec-to-launch-gimp-scr.patch View (1006 Bytes) hybridwipe, 10/28/2015 09:03 AM


Related issues

Related to Tails - Feature #7377: Improve Windows 8 camouflage Rejected 04/24/2014
Copied to Tails - Feature #9958: Don't display the splash screen for LibreOffice in Windows Camouflage mode Rejected 08/09/2015

Associated revisions

Revision cc744db8 (diff)
Added by hybridwipe about 4 years ago

tails-prepare-win8-theme: add wrapper scripts for gimp/scribus to avoid showing splash screens in win8 mode

Will-fix: #5530

History

#1 Updated by intrigeri about 6 years ago

  • Priority changed from Normal to Low
  • Starter set to No

#2 Updated by BitingBird over 5 years ago

  • Related to Feature #6342: Update Windows camouflage for GNOME3 added

#3 Updated by BitingBird over 5 years ago

  • Subject changed from improve Windows Camouflage to Improve Windows Camouflage

#4 Updated by alant over 5 years ago

easy-to-access shutdown button

Done

add a shortcut to the desktop in the bottom panel

This wouldn't look like win8

add --no-splash startup setting to those applications: scribus, inkscape (?)

Please create a specific ticket for that one.

#5 Updated by alant over 5 years ago

  • Related to deleted (Feature #6342: Update Windows camouflage for GNOME3)

#6 Updated by alant over 5 years ago

#7 Updated by BitingBird over 5 years ago

  • Subject changed from Improve Windows Camouflage to Windows Camouflage: add @--no-splash@ startup setting to some applications
  • Description updated (diff)

I changed the title and description, since the ticket had no other interest anymore.

#8 Updated by intrigeri over 5 years ago

  • Subject changed from Windows Camouflage: add @--no-splash@ startup setting to some applications to Don't display the splash screen for some applications

#9 Updated by intrigeri over 5 years ago

  • Subject changed from Don't display the splash screen for some applications to Don't display the splash screen for some applications in Windows Camouflage mode

#10 Updated by anonym over 5 years ago

  • Category set to Camouflage

#11 Updated by hybridwipe over 4 years ago

Using tails 1.4.1, I tested a few apps:
gimp: splash is shown, but suppressed with --no-splash
inkscape: no splash is shown
scribus: splash is shown, but suppressed with --no-splash

I looked in the source but couldn't find any reference to --no-splash or anything related for inkscape that I could replicate.

#12 Updated by BitingBird over 4 years ago

I asked hybridwipe to check without camouflage, and inkscape doesn't have a splashscreen either. They probably removed it in a recent version.

#13 Updated by BitingBird over 4 years ago

  • Description updated (diff)

removed inkscape from description, added gimp

#14 Updated by hybridwipe about 4 years ago

I've attached a patch for review. While it's probably possible to change the icon in the application menu using gsettings or something else as user, that doesn't prevent the user from running either program via the command line or some other GUI program and that option being ignored. Instead, I've opted to rename the executable to $executable-real and replace the original with a simple script that always sets --no-splash

#15 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to hybridwipe
  • QA Check set to Dev Needed

I've attached a patch for review.

Thanks!

While it's probably possible to change the icon in the application menu using gsettings or something else as user, that doesn't prevent the user from running either program via the command line or some other GUI program and that option being ignored. Instead, I've opted to rename the executable to $executable-real and replace the original with a simple script that always sets --no-splash

Makes sense to me. But the right way to replace files shipped by Debian packages is dpkg-divert; you'll find examples by git grep'ing our source tree :)

Also:

  • please quote everything that contains a variable for robustness
  • please add set -e and set -u for robustness

#16 Updated by hybridwipe about 4 years ago

Thanks for the review, here's a second patch with your changes incorporated.

#17 Updated by intrigeri about 4 years ago

  • Assignee changed from hybridwipe to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

Thanks!

#18 Updated by intrigeri about 4 years ago

  • Target version set to Tails_1.7

#19 Updated by hybridwipe about 4 years ago

  • Copied to Feature #9958: Don't display the splash screen for LibreOffice in Windows Camouflage mode added

#20 Updated by intrigeri about 4 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 20

(Reassigning to the current RM.)

#22 Updated by anonym about 4 years ago

  • % Done changed from 20 to 50
  • Feature Branch set to feature/5530-disable-splash-screens-in-camouflage-mode

#23 Updated by anonym about 4 years ago

Seems to work, but I think wrappers should call the wrapped application with exec (see my comment on #9958) but I can fix that later.

#25 Updated by anonym almost 4 years ago

  • Target version changed from Tails_1.7 to Tails_1.8

#26 Updated by intrigeri almost 4 years ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (anonym)
  • QA Check deleted (Ready for QA)

Windows Camouflage mode was removed for Tails 2.0 (Jessie), so I'm sorry but I don't think we'll take this patch :/

Also available in: Atom PDF