Project

General

Profile

Feature #5516

Feature #6015: Tails based on Wheezy

Have seahorse-nautilus fully replace seahorse-plugins

Added by Tails almost 6 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/09/2014
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
feature/6608-OpenPGP-signature-verification-in-Nautilus
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Squeeze's seahorse-plugins provided a variety of features that have disappeared in Wheezy.

Some of these features come back by installing a backport of seahorse-nautilus (currently in Jessie). For the other features (still missing in seahorse-nautilus 3.8.0), a newer upstream version, and a few other backports, are needed.

What is missing (blockers)

See sub-tasks.

What could be improved

Symmetric decryption

  • "Open with Decrypt File" or double-click managed to open an armored message with symmetric encryption
  • When decrypting such a message, a first dialog with "Encryption passphrase" appears, followed by another dialog "Decrypting" which takes away the focus from the passphrase dialog. That's annoying.

Other missing features (non-blockers)

... that are not regressions, and thus not blockers for Tails 1.1:

  • Symmetric encryption: #6607

What works

Support for multiple identities

  • There is a "Sign as" drop list when signing

Asymmetric encryption

  • There is a menu item "Encrypt..." below "Compress..."
  • Double-click on the file also works
  • The key selection window is a bit tiny by default. It really looks like the one from GPG Applet. But this one doesn't have the "Trust" column.
  • Encryption works: it creates a file with .pgp extension

Signing

  • There is a menu item "Sign" below "Encrypt..."
  • Works: creates a detached signature with .sig extension
  • It is also possible to sign while doing asymmetric encryption

Asymmetric decryption

  • Works: the menu item is on top of the list "Open with Decrypt file"
  • Asks where to save the file

Subtasks

Feature #6608: OpenPGP signature verification in NautilusResolved

Feature #7039: Install a backport of shared-mime-info 1.2+Resolved

Feature #7040: Wait for the shared-mime-info answer wrt. backporting for WheezyResolvedintrigeri

Feature #7058: Backport shared-mime-info 1.2+ for WheezyResolvedu

Feature #6647: Install an official backport for seahorse-nautilusResolvedintrigeri

Feature #6648: Wait for seahorse-nautilus maintainer's answer regarding backportsResolvedintrigeri

Feature #6651: Upload seahorse-nautilus to wheezy-backportsResolvedintrigeri

Feature #6663: Wait for seahorse-nautilus to make it out of the backports NEW queueResolvedintrigeri


Related issues

Related to Tails - Feature #6607: Symmetric encryption in seahorse-nautilus Resolved 01/03/2015

History

#1 Updated by intrigeri almost 6 years ago

  • Type of work changed from Wait to Code

#2 Updated by intrigeri over 5 years ago

  • Starter set to No

#3 Updated by intrigeri over 5 years ago

  • Parent task set to #6015

Marked as blocking for Wheezy, else that's a regression.

#4 Updated by intrigeri over 5 years ago

  • Subject changed from seahorse-nautilus to Install seahorse-nautilus

#5 Updated by intrigeri over 5 years ago

Added Debian bug reports.

#6 Updated by intrigeri over 5 years ago

  • Subject changed from Install seahorse-nautilus to Have seahorse-nautilus fully replace seahorse-plugins

#7 Updated by intrigeri about 5 years ago

  • Assignee set to intrigeri

#8 Updated by intrigeri about 5 years ago

  • Target version set to Tails_1.1

#9 Updated by intrigeri about 5 years ago

  • Status changed from Confirmed to In Progress

#10 Updated by intrigeri about 5 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA
  • Feature Branch set to feature/6608-OpenPGP-signature-verification-in-Nautilus

#11 Updated by anonym about 5 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#12 Updated by BitingBird almost 5 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF