Project

General

Profile

Feature #5487

Feature #6015: Tails based on Wheezy

Replace SCIM with the Wheezy equivalent

Added by Tails about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

At least scim-anthy, scim-pinyin, scim-uim and scim-hangul must be replaced by the Wheezy equivalent, that is likely uim-anthy or ibus-anthy and friends.


Related issues

Related to Tails - Feature #5624: support various input methods Resolved

History

#1 Updated by Tails about 6 years ago

  • Parent task set to #6015

#2 Updated by intrigeri about 6 years ago

  • Subject changed from wheezy: scim-anthy to Replace SCIM with the Wheezy equivalent
  • Starter set to No

#3 Updated by winterfairy almost 6 years ago

  • Assignee set to winterfairy

Everyone says ibus for wheezy, so that is the one.
- ibus-hangul (korean)
- ibus-pinyin (chinese)
- ibus-anthy (japanese)
- ibus-gtk (is this one needed?)

Removing all SCIM components and installing these ibus packages works on a running Tails 0.21 system (squeeze). I will proceed with trying to build a test ISO with these changes.

#4 Updated by intrigeri almost 6 years ago

wrote (04 Nov 2013 17:18:56 GMT) :

Removing all SCIM components and installing these ibus packages works on a running
Tails 0.21 system (squeeze). I will proceed with trying to build a test ISO with
these changes.

Awesome news :) Personally, I would base this work on the feature/wheezy branch.

#5 Updated by winterfairy almost 6 years ago

It's best if I can switch both squeeze and wheezy to IBus right? That is my intention. That won't make releasing wheezy harder right?

#6 Updated by winterfairy almost 6 years ago

I am going to assume "scim-uim" wasn't used for anything, and not find any replacement in ibus, unless someone tells me otherwise. The commit log there it was added stated it was needed for chinese language support, but I can find no other source that support this claim. Pinyin appears to be all that is needed for all chinese input needs.

Unrelated, wheezy may need "ibus-gtk3" and/or "ibus-clutter" too.

#7 Updated by winterfairy almost 6 years ago

This is fixed in "bugfix/ibus-wheezy" in my repo "winterfairy/tails".

Fixing this in squeeze will be tracked in #6206, as that is to fix that bug.

#8 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from winterfairy to intrigeri
  • QA Check set to Ready for QA

#9 Updated by intrigeri almost 6 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Merged in feature/wheezy.

#10 Updated by intrigeri almost 6 years ago

  • Target version set to Tails_1.1

#11 Updated by intrigeri almost 6 years ago

  • Target version deleted (Tails_1.1)

Also available in: Atom PDF