Project

General

Profile

Feature #5464

Revamp Greeter interface

Added by Tails about 6 years ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/11/2013
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Starter:
No
Affected tool:
Greeter

Description

Team: tchou, sajolida, alan, spencerone, ? (reviewer)


Subtasks

Feature #5319: New Greeter UI: integrate prototypesResolvedalant

Feature #6417: Evaluate tails-greeter revamp proposalsResolved

Bug #6418: Fix greeter mockups and test script availabilityResolved

Feature #5455: New greeter ui: test prototypesResolved

Feature #5782: New greeter ui: reseach pending specifications questionsRejected

Feature #8230: Greeter revamp: Phase 1Resolved

Feature #7549: Greeter revamp: Redesign "Welcome" and "Advanced"Resolved

Feature #7555: Greeter revamp: Validate wordings of "Welcome" and "Advanced"Resolved

Feature #7550: Greeter revamp: Implement prototype of "Welcome" and "Advanced"Resolved

Feature #8233: Greeter revamp: Review "Welcome" and "Advanced"Resolved

Feature #8236: Greeter revamp: Decide between 'play' and 'computer' logo for Start buttonResolved

Feature #8237: Greeter revamp: Decide a language iconResolved

Feature #8235: Greeter revamp: Validate "Welcome" and "Advanced" with expertsResolved

Feature #8238: Greeter revamp: Do user testing for "Welcome" and "Advanced"Resolved

Feature #8239: Greeter revamp: Release "Welcome" and "Advanced"Rejected

Feature #8241: Greeter revamp: Update all the other screens of the blueprintResolved

Feature #8244: Greeter revamp: Decide if we want to keep the wording "Quick setup"Resolved

Feature #7418: Rename network configuration options in Tails GreeterResolved

Feature #8523: Greeter revamp: Prepare the graphics for consumption by GtkResolved

Feature #8776: Greeter revamp: Rename "Start" button as "Start Tails"Resolved

Feature #8967: Greeter revamp: refine design according to expert feedbackResolved

Feature #8968: Greeter revamp: Redesign the "language" sectionResolved

Feature #8974: Greeter revamp: Feedback to the user which options are going to be usedResolved

Feature #8976: Greeter revamp: Consider merging "basic" and "advanced" screensResolved

Feature #5318: tails-greeter: support RTLResolved

Bug #11646: Fix hardcoded LTR occurencesResolved

Bug #11647: Test RTL support in the new greeterResolved

Bug #12056: Redraw UI RTL when switching to an RTL languageResolved

Feature #5594: tails-greeter: better administration password UIResolved

Feature #5680: New Greeter UI: update documentationResolved

Feature #11949: Prepare new Greeter documentation for inline helpResolved

Feature #5917: tails-greeter password field : Warn when caps-lock is ONResolved

Feature #6029: New Greeter UI: call for translationResolved

Bug #7372: tails-greeter buttons are not clear enough when checked or notResolved

Bug #7801: Confusing button checking at GreeterResolved

Feature #10812: Fix issues identified during UX testsResolved

Feature #10815: Auto-select region settings according to languageResolved

Feature #10816: Reword "Keyboard" to "Keyboard layout"Resolved

Feature #10822: Improve camouflage wording + screenshot (easy)Rejected

Feature #10824: "Start Tails" should perform "Unlock"Resolved

Feature #10825: Info bar about bridge configurationResolved

Feature #10826: Reword "bridge" to "Tor bridge"Resolved

Feature #10827: Reword "Privacy Settings" to "Additional Settings"Resolved

Feature #10828: Integrate prototype in the greeterResolved

Feature #5945: Display "waiting" mouse pointer during login, as long as the Greeter is upResolved

Feature #11308: Pressing Return in the new Greeter locale selection window should select topmost itemResolved

Bug #11311: The description of the selected option in the new Greeter's "Add Additional Setting" window is barely visible Resolved

Bug #11318: There should be user feedback when the greeter is loadingResolved

Bug #11319: There should be user feedback when the session is loadingDuplicate

Bug #11320: Fix keyboard navigation in add admin passwordResolved

Bug #11322: The Back button in the help window should be CloseResolved

Bug #11323: Do not adjust layout/formats if thy were manually setResolved

Bug #11324: Notification "Tails-greeter.py is ready" is unclearResolved

Bug #11325: Prevent opening several times the same documentationResolved

Bug #11326: Close popovers on double-clickResolved

Bug #11327: Clicking on "Disable" should close admin password popoverResolved

Feature #11428: "Screen Reader" does nothing in new GreeterResolved

Feature #11430: "Screen Keyboard" doesn't work in new GreeterResolved

Feature #11431: Pressing Enter in tree-like search tool should select first entry in new GreeterDuplicate

Feature #11432: Empty pop with multiple additional settings in new GreeterRejected

Feature #11433: Broken shortcuts to additional setting configuration in new GreeterRejected

Feature #11434: Add a keybinding for "Back" in new GreeterResolved

Feature #11435: Remove ':w' cruft in new Greeter codeResolved

Feature #11436: Pressing Enter when typing the persistence password should do "Unlock" in new GreeterResolved

Feature #11437: Remove description of additional setting in parenthesis in new GreeterResolved

Feature #11438: Review user-visible strings of new GreeterResolved

Feature #11469: Decrease welcome text trackingResolved

Feature #11470: Adding welcome text punctuationResolved

Feature #11472: Update Greeter iconsResolved

Feature #11473: Add list item dividersRejected

Feature #11475: Remove occasional list item label redundancyResolved

Feature #11476: Change 'Add Additional Setting' text to whiteDuplicate

Feature #11477: Increase 'MAC Spoofing' pop-over dialog paddingResolved

Feature #11644: Hide timezone selectionResolved

Feature #11653: Refine design of Encrypted Persistent StorageResolved

Feature #11654: Better Delete Additional setting buttonResolved

Bug #11312: The option's configuration window does not open anymore after adding and removing the optionRejected

Bug #11321: Remove the remove additional setting buttonResolved

Bug #11640: Additional settings change position when added, then removedRejected

Feature #11656: Redesign how to reset additional setting to default.Resolved

Feature #11655: Integrate the latest graphics if they are notDuplicate

Bug #11658: Fix Cancel in Add Additional SettingResolved

Bug #11947: Fix on-the-fly translation of the new GreeterResolved

Feature #11952: "An assistant will guide you to configure..." stays displayed even when bridges are deselectedResolved

Feature #11954: Smaller margins on MAC Address Spoofing dialog in new GreeterResolved

Feature #11955: Previous "Restart" button shoult "Shutdown" in new GreeterResolved

Bug #11957: Calling set_text on a label should update its value in the translation catalogResolved

Feature #11670: Triage all greeter ticketsResolved

Feature #11700: Use a systemd --user service instead of xdg autostart for tails-greeter-session-helperResolved

Bug #11704: Adjust Greeter's CSS for StretchResolved

Bug #11924: Make new Greeter's translatable strings use named placeholdersResolved

Feature #11996: Fix typo "suspiction" → "suspicion" in new GreeterResolved

Feature #12013: Publish a call for testing the revamped GreeterResolved

Feature #12055: Update test suite for Greeter revamp, phase 1Resolved

Feature #12058: Hide "Relock persistence storage" for nowResolved

Bug #12063: Keyboard-only usability regression for intrigeri's development use caseResolved

Feature #12064: Get rid of GNOME Flashback, Metacity and friendsResolved

Feature #12070: New Greeter doc: call for translationResolved

Bug #12079: New Greeter breaks startup of Terminal by setting invalid values for some LC_* variablesResolved

Bug #12093: Missing "Read only" option for persistence in new GreeterRejected

Bug #12200: The Greeter's release process is broken: POTFILES.in lists non-existing fileResolved

Feature #12247: Remove lists of if clausesResolved

Bug #12359: Language selector in the revamped Greeter always picks top entry when Enter is pressedResolved

Bug #12370: Greeter's screensaver is Debian brandedResolved

Feature #12373: Greeter should honor "debug" kernel command line parameterResolved

Feature #12382: Don't mention "firewall" in Tails Greeter anymoreResolved

Bug #12462: Alt+F4 is closing the Greeter's windowResolved

Bug #12509: The Greeter should have initial keyboard focus on the default action.Resolved

Bug #12547: Selecting Language "English - x" results in the wrong keyboard layout for many values of xResolved

Feature #9922: Greeter revamp: Phase 0.5 - Change the position of language settingsRejected

Feature #11643: Greeter revamp: Phase 1.1Rejected

Feature #10813: Bonus identified during UX testRejected

Feature #11429: "Larger Text" does not refresh the whole view in new GreeterResolved

Feature #11471: 'Help' button hover state Rejected

Feature #12077: Rephrase Internet connection settingsRejected

Feature #12078: Consider renaming the Add button for adding additional settingRejected

Bug #12249: Greeter's Formats popover may be cutResolved

Bug #12364: Race condition at greeter startupRejectedalant

Bug #12386: Greeter sometimes fails to set Admin password on StretchDuplicatealant

Feature #12069: Greeter revamp: phase 1.2Rejected

Feature #9004: Greeter revamp: Rework the "remember" options for language settingsRejected

Feature #10814: Add icon to easily launch virtual keyboardResolved

Feature #10817: Split keyboard variantResolved

Feature #10823: Click outside of the dialog closes the dialogRejected

Feature #12640: Update/rethink next steps for the Greeter revampResolved


Related issues

Related to Tails - Bug #11073: greeter: dropdown menues not displayed properly Rejected 02/07/2016
Related to Tails - Feature #11048: Permanently remove the rest of the keyboard layout Confirmed 02/03/2016
Duplicated by Tails - Feature #7918: Adding keyboard language is too hard in Tails 1.1 Duplicate

History

#1 Updated by Tails about 6 years ago

  • Priority changed from Normal to High

#2 Updated by Tails about 6 years ago

  • Priority changed from Normal to High

#3 Updated by Tails about 6 years ago

  • Priority changed from Normal to High

#4 Updated by intrigeri about 6 years ago

  • File greeter_persistence_kbd.png added
  • File menu.png added
  • File mockup.py added
  • File README added
  • File greeter.png added
  • File greeter-opt-adm.png added
  • File greeter-opt-locale.png added
  • File greeter-opt-persistence.png added
  • File tails-greeter1.ui added
  • File greeter_persistence.png added

#5 Updated by intrigeri about 6 years ago

  • File tails-greeter2.ui added
  • File tails-greeter3.ui added
  • File tails-greeter4.ui added
  • File tails-greeter5.ui added

#6 Updated by intrigeri about 6 years ago

  • Type of work set to Code

Type of work: Code

#7 Updated by alant about 6 years ago

  • Assignee set to alant
  • Starter set to No

#8 Updated by winterfairy almost 6 years ago

I am slightly worried about the submenues hidden behind icons in the mockup images posted here. Clicking back and forth between menues takes time is quite frustrating. There is almost no visibility, and the user must keep track of many more states he/she may be in himself/herself.

Just so we do not create a user-design mess like the new installer in Fedora 18/19 :)

Also, renaming "Options" to "Advanced options" may be preferrable, so a first-time user know that he/she does not have to worry about them. If a new user is presented with too many options, they tend to give up and leave before even trying (from what I have seen IRL).

#9 Updated by intrigeri almost 6 years ago

  • File deleted (tails-greeter1.ui)

#10 Updated by intrigeri almost 6 years ago

  • File deleted (tails-greeter3.ui)

#11 Updated by intrigeri almost 6 years ago

  • File deleted (tails-greeter4.ui)

#12 Updated by intrigeri almost 6 years ago

  • File deleted (tails-greeter5.ui)

#13 Updated by intrigeri almost 6 years ago

  • File deleted (tails-greeter2.ui)

#14 Updated by intrigeri almost 6 years ago

  • File deleted (greeter-opt-persistence.png)

#15 Updated by intrigeri almost 6 years ago

  • File deleted (greeter_persistence.png)

#16 Updated by intrigeri almost 6 years ago

  • File deleted (greeter-opt-locale.png)

#17 Updated by intrigeri almost 6 years ago

  • File deleted (greeter_persistence_kbd.png)

#18 Updated by intrigeri almost 6 years ago

  • File deleted (menu.png)

#19 Updated by intrigeri almost 6 years ago

  • File deleted (mockup.py)

#20 Updated by intrigeri almost 6 years ago

  • File deleted (greeter.png)

#21 Updated by intrigeri almost 6 years ago

  • File deleted (greeter-opt-adm.png)

#22 Updated by intrigeri almost 6 years ago

  • File deleted (README)

#23 Updated by BitingBird over 5 years ago

  • Blocks Feature #6811: Add Tails Greeter option for disabling networking added

#24 Updated by BitingBird over 5 years ago

  • Blocks deleted (Feature #6811: Add Tails Greeter option for disabling networking )

#25 Updated by BitingBird over 5 years ago

  • Parent task set to #6811

#26 Updated by intrigeri over 5 years ago

  • Parent task deleted (#6811)

#27 Updated by intrigeri over 5 years ago

  • Blocks Feature #6811: Add Tails Greeter option for disabling networking added

#28 Updated by intrigeri over 5 years ago

This task is blocking not only the offline mode, but also any other option we might want to add in the Greeter. So, IMO the right relationship is really "blocks" (since #5464 can block N>1 tickets) rather than "subtask of #6811" (since #5464 can only have one parent ticket). That's why I have reverted this ticket's relationships to its previous state.

#29 Updated by BitingBird over 5 years ago

  • Subject changed from tails-greeter: revamp UI to Tails-greeter: revamp UI

#30 Updated by intrigeri over 5 years ago

  • Subject changed from Tails-greeter: revamp UI to Revamp the Greeter interface

#31 Updated by intrigeri over 5 years ago

  • Related to Bug #7372: tails-greeter buttons are not clear enough when checked or not added

#32 Updated by BitingBird over 5 years ago

  • Subject changed from Revamp the Greeter interface to Revamp tails-greeter interface

#33 Updated by BitingBird over 5 years ago

  • Related to Feature #5782: New greeter ui: reseach pending specifications questions added

#34 Updated by BitingBird over 5 years ago

  • Related to Feature #5455: New greeter ui: test prototypes added

#35 Updated by BitingBird about 5 years ago

  • Related to deleted (Feature #5455: New greeter ui: test prototypes)

#36 Updated by BitingBird about 5 years ago

  • Related to deleted (Feature #5782: New greeter ui: reseach pending specifications questions)

#37 Updated by alant about 5 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to feature/5464-revamp-ui

Basic integration of the proposed UI can be tested in feature/5464-revamp-ui. See #5319 for details.

#38 Updated by alant about 5 years ago

The prototypes were tested and feedback gathered, see blueprint for the results.

#39 Updated by intrigeri about 5 years ago

  • Blocks Feature #7723: Make it possible to opt-in for I2P in the Greeter added

#40 Updated by sajolida about 5 years ago

  • Blueprint changed from https://tails.boum.org/blueprint/tails-greeter:_revamp_UI to https://tails.boum.org/blueprint/greeter_revamp_UI/

#41 Updated by intrigeri almost 5 years ago

  • Duplicated by Feature #7918: Adding keyboard language is too hard in Tails 1.1 added

#42 Updated by sajolida almost 5 years ago

  • Subject changed from Revamp tails-greeter interface to Revamp Greeter interface
  • Assignee deleted (alant)

#43 Updated by BitingBird over 4 years ago

  • Affected tool set to Greeter

#44 Updated by BitingBird over 4 years ago

  • Related to Feature #5501: Persistence preset: locale and accessibility options (language, keyboard, and formats) in Greeter added

#45 Updated by sajolida about 4 years ago

  • Description updated (diff)

#46 Updated by sajolida almost 4 years ago

  • Target version deleted (Sustainability_M1)

#47 Updated by anonym almost 4 years ago

  • Blocks deleted (Feature #6811: Add Tails Greeter option for disabling networking )

#48 Updated by elouann over 3 years ago

  • Related to Bug #11073: greeter: dropdown menues not displayed properly added

#49 Updated by alant over 2 years ago

  • Related to deleted (Bug #7372: tails-greeter buttons are not clear enough when checked or not)

#50 Updated by alant over 2 years ago

  • Feature Branch deleted (feature/5464-revamp-ui)

#51 Updated by emmapeel over 2 years ago

  • Duplicated by Bug #12198: UI for Tor config doesn't show up until there's net connection added

#52 Updated by intrigeri over 2 years ago

  • Duplicated by deleted (Bug #12198: UI for Tor config doesn't show up until there's net connection)

#53 Updated by sajolida over 2 years ago

  • Blocks deleted (Feature #7723: Make it possible to opt-in for I2P in the Greeter)

#54 Updated by intrigeri over 2 years ago

  • Related to deleted (Feature #5501: Persistence preset: locale and accessibility options (language, keyboard, and formats) in Greeter)

#55 Updated by u about 2 years ago

  • Assignee set to alant

Assigning the parent ticket to alan to keep track.

#56 Updated by u about 1 year ago

  • Related to Feature #11048: Permanently remove the rest of the keyboard layout added

#57 Updated by sajolida 8 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (alant)

We did it, yeah!!!

Also available in: Atom PDF