Project

General

Profile

Bug #5376

Feature #5978: test suite: usb install feature

test suite: fix shutdown step

Added by Tails over 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
No
Affected tool:

Description

In the "Writing files to a read-only-enabled persistent partition" scenario:

And I completely shutdown Tails                                    # features/step_definitions/common_steps.rb:402
  The image 'TailsEmergencyShutdownHalt.png' did not match in this region. (Sikuli::ImageNotFound)
  ./features/support/helpers/sikuli_helper.rb:31:in `wait_and_click'
  ./features/step_definitions/common_steps.rb:407:in `(root)':in `/^I completely shutdown Tails$/'
  features/usb_install.feature:103:in `And I completely shutdown Tails'

History

#1 Updated by intrigeri about 6 years ago

  • Category set to Test suite
  • Starter set to No

#2 Updated by intrigeri almost 6 years ago

  • Tracker changed from Feature to Bug
  • Parent task set to #5978

#3 Updated by intrigeri almost 6 years ago

  • Assignee set to bertagaz
  • Type of work changed from Code to Test

I can't reproduce this on bare metal (test/rjb-migration, today's build of devel). Reassigning to someone who runs this with nested virtualization. bertagaz, if you can't reproduce this, please close this ticket as "rejected".

#4 Updated by intrigeri almost 6 years ago

  • Status changed from Confirmed to 11
  • Assignee deleted (bertagaz)
  • Target version set to Tails_0.23
  • % Done changed from 0 to 100

Neither anonym nor I can reproduce since the rjb branch was merged, so calling it resolved.

#5 Updated by sajolida almost 6 years ago

  • Category changed from Test suite to Infrastructure
  • Status changed from 11 to Confirmed
  • Assignee set to sajolida
  • Priority changed from Normal to Low

#6 Updated by sajolida almost 6 years ago

  • Category changed from Infrastructure to Test suite
  • Status changed from Confirmed to 11
  • Assignee deleted (sajolida)
  • Priority changed from Low to Normal

#7 Updated by anonym over 5 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF