Project

General

Profile

Feature #5300

liveusb-creator skip copying iso files

Added by Tails almost 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Installation
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:

Description

We've seen such issues at "Clone & upgrade" time reported quite often recently on our various support channels:

bc. Not enough free space on device.
1712MB ISO + 0MB overlay > 1485MB free space

Every time it was caused by random cruft (generally a Tails ISO) added to the source USB stick, and every time we were able to communicate with the reporter long enough, removing that cruft fixed the issue.

First, there seems to be a bug in the 1712MB size computation: even when random files were added on the source partition, given the size of the source partition is the same as the size of the target partition, it has to fit. This should be trivial to fix.

Second, perhaps we could add a very dumb and simple filter to the clone process, to skip copying .iso files. This would have avoided the issue in all cases I've been given to see.

Alternative proposal

Add a file listing all files expected in a Tails system partition (should be easy to create at build time) and only copy these files? That would prevent the cloned Tails to carry random shit.

But that seems more complicated to implement. So maybe the easiest, the better.

History

#1 Updated by intrigeri almost 6 years ago

  • Starter set to Yes

#2 Updated by intrigeri over 5 years ago

Skipping *.iso when cloning should be a trivial oneliner change to liveusb/source.py, in the clone method of the RunningLiveSystemSource class.

#3 Updated by intrigeri over 5 years ago

  • Status changed from Confirmed to Fix committed

Pending for 0.21.

#4 Updated by intrigeri over 5 years ago

  • Category set to Installation

#5 Updated by intrigeri over 5 years ago

  • Status changed from Fix committed to Resolved

#6 Updated by Dr_Whax almost 3 years ago

  • Description updated (diff)
  • Target version set to 2017

#7 Updated by intrigeri almost 3 years ago

  • Description updated (diff)
  • Target version deleted (2017)

(This was really about #5301.)

Also available in: Atom PDF