Project

General

Profile

Bug #17501

Unsteady Ethernet Connection with RTL8111/8168/8411 since Tails 4

Added by goupille about 1 month ago. Updated 12 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

a user reported that with tails 4, and with every version released since then, Tails notify the user that Tor is connected, then the connection drops and network manager display a "no connection" icon. after a few seconds the connection is up again, then drops, and again and again.

the issue was not there in tails 3.*

the ethernet adapter is

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168]
(rev 11)

disabling mac spoofing does not help.

apparently if a software using internet is started the connection is not dropping anymore

before tails 4, the connection rate was limited to 100MB/s, but since then it is marked as 1000MB/s. setting manually the connection to 100MB/s (with ethtool) solve the issue.

History

#1 Updated by goupille about 1 month ago

apparently it is caused by a weird configuration on the modem of the user (one ethernet port was set to 100MB/s), apparently tails 3 and Ubuntu set the ethernet rate to 100MB/s automatically, but Tails 4 seems not to do so.

#2 Updated by goupille 28 days ago

goupille wrote:

apparently if a software using internet is started the connection is not dropping anymore

I misunderstood, in fact, the connection drops from the moment it is used

#3 Updated by intrigeri 12 days ago

  • Category set to Hardware support

#4 Updated by intrigeri 12 days ago

  • Status changed from New to Rejected

Hi goupille,

goupille wrote:

I misunderstood, in fact, the connection drops from the moment it is used

FWIW, I'm not sure how to conciliate this with "Tails notify the user that Tor is connected, then the connection drops": tor does use the network to connect.

apparently it is caused by a weird configuration on the modem of the user (one ethernet port was set to 100MB/s), apparently tails 3 and Ubuntu set the ethernet rate to 100MB/s automatically, but Tails 4 seems not to do so.

Looking this up online I indeed see lots of problems with speed auto-negotiation with this network card.

Given:

  • the rather uncommon setup
  • the user found a workaround that works for them already
  • that workaround assumes too much tech skills to be generally useful

… I don't think we should spend time documenting this workaround.

Also available in: Atom PDF