Project

General

Profile

Bug #17486

Upgrade Let's Encrypt client to be ACMEv2 compatible

Added by intrigeri about 1 month ago. Updated 14 days ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

All our Stretch systems currently use the ACMEv1 protocol to request LE certs.
Beginning June 1, 2020, this will stop working.


Related issues

Blocks Tails - Feature #13242: Core work: Sysadmin (Maintain our already existing services) Confirmed 06/29/2017

History

#1 Updated by intrigeri about 1 month ago

  • Blocks Feature #13242: Core work: Sysadmin (Maintain our already existing services) added

#2 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from intrigeri to Sysadmins
  • Target version changed from Tails_4.6 to Tails_4.5

https://git.tails.boum.org/puppet-tails/commit/?id=6f16b55853e3ee7a4d5a2920f83625b6e5a39808 should fix it.

Let's come back to this in a few weeks and close this ticket if we've received no new warning email from Let's Encrypt by then.

#3 Updated by zen about 1 month ago

  • Assignee changed from Sysadmins to zen

#4 Updated by zen 14 days ago

  • Status changed from Needs Validation to Resolved

I think this is resolved because (1) it's been almost a month and we got no warnings, and (2) the certificate for https://redmine.tails.boum.org was issues on March 3rd 2020, after the change was in place.

Also available in: Atom PDF