Project

General

Profile

Bug #17480

Since Tails 4.3 upgrade Intel WiFi is broken

Added by natrium about 1 month ago. Updated 11 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

I don't use WiFi that often, but since I recently upgrade to 4.3 I noticed WiFi is broken.
I guess 4.3 update broke it.
It definitly worked fine for Tails 4.0.

lspci -v | grep "Network controller" 
00:14 Network controller: Intel Corporation Cannon Point-LP CNVi [Wireless-AC] (rev 30)

The menu bar WiFi icon appears and disappears every second.
Likewise in the Settings window the WiFi option appears/disappears every second.

When it flashes up it I can see "No WiFi Adapter Found".

I've tried disabling MAC spoofing but it doesn't fix it.


Related issues

Related to Tails - Bug #17499: AC 9560 Wifi doesn't work in 4.3 Resolved

History

#1 Updated by intrigeri about 1 month ago

Hi natrium!

I don't use WiFi that often, but since I recently upgrade to 4.3 I noticed WiFi is broken.
I guess 4.3 update broke it.
It definitly worked fine for Tails 4.0.

Sorry about that.

Do you remember if you tried any Tails 4.x version between 4.0 and 4.3?
I'm wondering if it might be that this problem was introduced in 4.1.1 (a bunch of similar problems were).

Also, please try the experimental image from https://nightly.tails.boum.org/build_Tails_ISO_feature-17477-linux-5.4.19-force-all-tests/lastSuccessful/archive/build-artifacts/, that includes updated drivers.

#2 Updated by intrigeri about 1 month ago

  • Category set to Hardware support

#3 Updated by natrium about 1 month ago

Sorry about that.

That's not a problem at all. Thank you for working on Tails!

For sure I did update since 4.0 (I'd say a couple times at least).
I'll try to test the experimental image if I can find a spare USB stick.
Thanks.

#4 Updated by natrium about 1 month ago

I don't suppose there is an update log on the system?

#5 Updated by natrium about 1 month ago

Where can I download a copy of the public key that was used to sign the 'tails-build-artifacts.shasum.asc'? (Preferably somewhere on the official TLS secured Tails website). Thanks.

#6 Updated by natrium about 1 month ago

I'm unable to test the experimental image. I can't find the key so I can't verify the gpg signature. Sorry.

#7 Updated by intrigeri 26 days ago

  • Related to Bug #17499: AC 9560 Wifi doesn't work in 4.3 added

#8 Updated by intrigeri 26 days ago

That's not a problem at all. Thank you for working on Tails!

:)))

I'll try to test the experimental image if I can find a spare USB stick.

Great.

I don't suppose there is an update log on the system?

Unfortunately, no.

Where can I download a copy of the public key that was used to sign the 'tails-build-artifacts.shasum.asc'?
I'm unable to test the experimental image. I can't find the key so I can't verify the gpg signature. Sorry.

It's AA65 3423 DBE1 0866 0B18 3B17 D83A 438B 2F91 6605, probably on the keyservers. But really these signatures are just confusing and not very useful: such experimental_ image are produced by a CI system that is not 100% trustworthy, so don't rely on it for anything besides testing hardware support.

Anyway, the link I gave us has expired, please use https://nightly.tails.boum.org/build_Tails_ISO_stable/lastSuccessful/archive/build-artifacts/ instead.

Finally, this looks related to #17499. Could you please share the output of this command: sudo journalctl | grep iwlwifi ?
Thanks in advance!

#9 Updated by natrium 16 days ago

Here's that journalctl report. I've trimmed it at the end as it just repeats over and over.
I hope there no private MAC addreses or anything in it. Please delete it if there is. Thanks.

[Removed log as per author request.]

#10 Updated by intrigeri 16 days ago

  • Status changed from New to Confirmed
  • Assignee set to natrium

Hi natrium,

thanks a lot, this helps!

This looks very much like #17499, that the affected user told us was fixed in Tails 4.4.
Could you please test 4.4?

#11 Updated by natrium 14 days ago

I'll try 4.4 but there is a problem with the PGP key that signed it. The Debian-keyring method described1 isn't working as described.

After importing "Stefano Zacchiroli" key it does not appear as the tutorial says it should!!?? A couple of other guys appear "Holger Levsen" and "gregor herrmann" but no "Stefano Zacchiroli".

Any ideas about that?

Thanks.

[1] https://tails.boum.org/install/expert/usb/index.en.html

#12 Updated by intrigeri 13 days ago

Hi,

I did what you asked for, but keep in mind that anyone who is subscribed to a Redmine issue has a copy of the original notes posted here.

I'll try 4.4

Great, thank you!

but there is a problem with the PGP key that signed it. The Debian-keyring method described1 isn't working as described.

After importing "Stefano Zacchiroli" key it does not appear as the tutorial says it should!!?? A couple of other guys appear "Holger Levsen" and "gregor herrmann" but no "Stefano Zacchiroli".

Any ideas about that?

We're aware of this problem (#17475).
Not to say it's fine that our doc is currently broken, but experience shows that we're not able to support OpenPGP usage properly, for users who need such support.
I would suggest you use the other verification method we offer, i.e. using our browser add-on :)

#13 Updated by natrium 12 days ago

I did what you asked for, but keep in mind that anyone who is subscribed to a Redmine issue has a copy of the original notes posted here.

Awesone, thank you intrigeri, I really appreciate that. I'm such a klutz of late.

We're aware of this problem (#17475).
Not to say it's fine that our doc is currently broken, but experience shows that we're not able to support OpenPGP usage properly, for users who need such support.

Thanks for the bug link. I had a hunch the key was good. Its just the final tutorial left a bit concerned.

Have the TAILS developers ever considered using OpenBSD's signify instead of Open PGP to sign TAILS releases?[1,2,3] It seems to be much simpler. (Its in Debian as signify-openbsd)
Or there's the very similar (and compatible with signify) minisign .[4]

I'll try 4.4 but it will take a day or two. A bit snowed under with covid-19 extra workload.

Thanks again for the deletion.

[1] https://blog.gtank.cc/modern-alternatives-to-pgp/
[2] https://flak.tedunangst.com/post/signify
[3] https://packages.debian.org/search?suite=all&searchon=names&keywords=signify-openbsd
[4] https://jedisct1.github.io/minisign/

#14 Updated by natrium 12 days ago

Can confirm the issue is fixed. WiFi works in TAILS 4.4.
Thanks again.

#15 Updated by intrigeri 11 days ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (natrium)
  • Target version set to Tails_4.4

natrium wrote:

Can confirm the issue is fixed. WiFi works in TAILS 4.4.

Thanks for confirming!

Also available in: Atom PDF