Project

General

Profile

Feature #17452

Feature #6560: UEFI Secure boot

Figure out what to do with VirtualBox dkms modules vs. Secure Boot

Added by intrigeri 25 days ago. Updated about 10 hours ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Virtualization
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

Presumably, all Tails started in VirtualBox won't have Secure Boot enabled, either because they're started from DVD (and we only support Secure Book when booting from USB and UEFI), or because VirtualBox does not support Secure Boot (does it?), so the unsigned VirtualBox dkms modules should be loaded just fine. Correct?
If that assumption is incorrect, then I don't think we have to do anything here.
Else, we probably need to update some code and documentation.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

History

#1 Updated by intrigeri 25 days ago

#2 Updated by segfault about 14 hours ago

  • Status changed from Confirmed to Resolved

intrigeri wrote:

Presumably, all Tails started in VirtualBox won't have Secure Boot enabled, either because they're started from DVD (and we only support Secure Book when booting from USB and UEFI), or because VirtualBox does not support Secure Boot (does it?), so the unsigned VirtualBox dkms modules should be loaded just fine. Correct?

I think you're right. I couldn't find anything about VirtualBox supporting Secure Boot. Even if that was possible somehow, we only support booting Tails from an ISO attached as a DVD in VirtualBox.

If that assumption is incorrect, then I don't think we have to do anything here.

Agreed.

#3 Updated by intrigeri about 10 hours ago

  • % Done changed from 0 to 100

Also available in: Atom PDF