Project

General

Profile

Feature #17451

Feature #8415: Migrate from aufs to overlayfs

Update / clean up remaining aufs-related bits

Added by intrigeri 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
feature/8415-overlayfs+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

We should git grep -i aufs and either update or clean up each occurrence.

For example, aufs support in the IUK generation code can go away, and IIRC we have some kludges to workaround aufs bugs somewhere.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 3b016498 (diff)
Added by intrigeri about 1 month ago

Vagrant build-tails script: drop obsolete reference to aufs (refs: #17451)

We've ditched aufs usage from our build code in Tails 2.4.

Revision ee6dd947 (diff)
Added by intrigeri about 1 month ago

Upgrader test suite: exercise overlayfs-based code paths by default (refs: #17451)

Revision 91fc085d (diff)
Added by intrigeri about 1 month ago

Update aufs-specific comment (refs: #17451)

Revision 47d70da0 (diff)
Added by intrigeri about 1 month ago

Update various contributors doc: aufs → overlayfs (refs: #17451)

Revision 95dae0f3 (diff)
Added by intrigeri about 1 month ago

Update comment for overlayfs (refs: #17451)

History

#1 Updated by intrigeri 2 months ago

#2 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri

Here's the list of occurrences:

  • config/chroot_local-hooks/04-change-gids-and-uids: tracked by #17256
  • config/chroot_local-includes/usr/local/lib/initramfs-pre-shutdown-hook: tracked on #15146
  • config/chroot_local-includes/usr/local/lib/tails-unblock-network
  • config/chroot_local-includes/usr/src/iuk/:
    • Updated the test suite locally to exercise overlayfs by default.
    • I'm wary of fully removing support for generating IUKs based on aufs as part of the first iteration of this work, because I'd like to make it easy to switch back to aufs if needed, so I've created #17489 to clean this up later
  • vagrant/provision/assets/build-tails: AIUI that's a leftover of an older version of our build system, that used aufs for space optimization; we ditched that in Tails 2.4 → removed-
  • wiki/src/contribute/Linux_kernel.mdwn
  • wiki/src/contribute/design.mdwn
  • wiki/src/contribute/design/Unsafe_Browser.mdwn
  • wiki/src/contribute/design/application_isolation.mdwn
  • wiki/src/contribute/design/incremental_upgrades/archive.mdwn: historical info, that's OK
  • wiki/src/contribute/design/memory_erasure.mdwn: tracked on #15146
  • wiki/src/contribute/release_process.mdwn
  • wiki/src/contribute/release_process/tails-iuk.mdwn: tracked on #17489
  • wiki/src/contribute/roadmap.mdwn

And in puppet-tails.git:

  • modules/tails/manifests/iuk_builder.pp installs aufs-dkms: tracked on #17489

#3 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to segfault

#4 Updated by segfault about 1 month ago

intrigeri wrote:

Here's the list of occurrences:

  • config/chroot_local-includes/usr/local/lib/tails-unblock-network

aufs is still mentioned in two comments. The first one is still valid, but I'm not sure how useful the information "this is a documented possibility with aufs' noxino mount option" is if we don't use aufs.

  • wiki/src/contribute/Linux_kernel.mdwn

I see a reference to submodules/aufs4-standalone, which is called aufs-standalone on stable, and is deleted on the feature branch.

#5 Updated by segfault about 1 month ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from segfault to intrigeri

#6 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to segfault
  • config/chroot_local-includes/usr/local/lib/tails-unblock-network

aufs is still mentioned in two comments. The first one is still valid, but I'm not sure how useful the information "this is a documented possibility with aufs' noxino mount option" is if we don't use aufs.

Right, I missed the 2nd one! Apparently overlayfs can have the same problem; now updated.

  • wiki/src/contribute/Linux_kernel.mdwn

I see a reference to submodules/aufs4-standalone, which is called aufs-standalone on stable, and is deleted on the feature branch.

Where do you see this? I can find it neither with git grep, nor on https://salsa.debian.org/tails-team/tails/blob/feature/8415-overlayfs+force-all-tests/wiki/src/contribute/Linux_kernel.mdwn.

#7 Updated by segfault about 1 month ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (segfault)
  • % Done changed from 0 to 100

intrigeri wrote:

  • config/chroot_local-includes/usr/local/lib/tails-unblock-network

aufs is still mentioned in two comments. The first one is still valid, but I'm not sure how useful the information "this is a documented possibility with aufs' noxino mount option" is if we don't use aufs.

Right, I missed the 2nd one! Apparently overlayfs can have the same problem; now updated.

LGTM

  • wiki/src/contribute/Linux_kernel.mdwn

I see a reference to submodules/aufs4-standalone, which is called aufs-standalone on stable, and is deleted on the feature branch.

Where do you see this? I can find it neither with git grep, nor on https://salsa.debian.org/tails-team/tails/blob/feature/8415-overlayfs+force-all-tests/wiki/src/contribute/Linux_kernel.mdwn.

Oops, that was actually in Linux_kernel.html, so an old build artifact.

Also available in: Atom PDF